[LH4641] "Remove from project bookmarks" option not working.

Hey, guys!

As stated above, I’ve had strange results using the “Remove from project bookmarks” option from the right-click menu over folders/files in the binder. The “add” counterpart works fine, but “remove” doesn’t seem to be doing anything.

Here’s what happened.

  1. Tried adding folder X to project Bookmark. Success.
  2. Tried removing by right-clicking on the folder in the binder and selecting “remove from project bookmarks”. Nothing happened.
  3. Navigated to a different window in the inspector menu, then went back to project bookmarks. Folder X was still there.
  4. Restarted Scrivener. Folder X was no longer in project bookmarks.

Strangely, that was the only time I obtained this result.

  1. I tried repeating steps 1-4 several times, and even after several restarts, the files remained bookmarked.

It’s worth mentioning that I am actually able to remove them by using the right-click menu in the bookmark inspector window and clicking “Delete selected bookmark.”

But as it stands, the “Remove from project bookmarks” option isn’t doing anything.

I appreciate the help. RC8 is looking awesome!

Ian

Thanks for reporting this Ian. This has been fixed and will be available in the next release.

Thank you guys for being so close to the community! This software is already turning out to be amazing :smiley: :smiley: