[LH4663] Doing Find in Scrivenings Mode

Version: 2.9.9.9 Beta (1017023) 64-bit - 14 Aug 2020 (HiDPI)
Win10 Home, 16GB RAM (8.7GB in use)

In Scrivenings mode, A find window cannot move forward past the file it’s in… (will not find beyond the first file boundary). HOWEVER, Previous WILL find across all documents in the scrivenings mode. After that worked, I tried going to the next again, but it will not go past a document boundary.

(In case it’s helpful, I have a video.)

Here’s the video:
dropbox.com/s/1dqe0d26yus26 … 2.wmv?dl=0

Could not reproduce, here it searchs in next documents.
Did you try to activate then deactivate “search in this document” ?

I

I can’t reproduce this either. If you create a new project and try the same test there, do you get the same results?

Also, I notice from your video that you’re storing your project in Google Drive. We strongly advise against using Google Drive to store live Scrivener projects, as that sync service doesn’t handle Scrivener’s project file format well. We have an advisory about this here: scrivener.tenderapp.com/help/kb … e-advisory

Thanks. I’m trying to find a setting or option for “search in this document” but so far, cannot find it.

The new test project worked correctly. Hmmmm. I can find no option to search a specific document (e.g. in scrivenings mode). What options/settings might cause this?

(FYI: The project is now on DropBox, but still has this issue. I always use GD and did that before realizing L&L’s recommendation.)

I don’t know the internals of Scrivener (I’m fairly new, but mostly tech savvy) so I’ll ask, Is there a way to “rebuild” or “reindex” or some concept like that? (I didn’t notice anything like that in “Project” menu.

I HAVE WORKAROUND! But, this is getting weirder.

  1. Open my project (search forward won’t work across documents in Scrivenings mode)
  2. Open my newly created test project (in addition to my regular project) AND CLOSE the test project IMMEDIATELY doing NOTHING in it. After that, my regular project searches correctly. I’m not kidding.

Here’s a video: dropbox.com/s/wmdpvkbsnyjvz … 5.wmv?dl=0

I use RegEx a lot. My project search often has RegEx selected. But I can switch to “Any Word” (instead of RegEx) and it will NOT REMEMBER IT when I close, then open the project again. MAYBE I installed RC9 when RegEx was selected.
I do NOT think this issue is related (but I thought was… it once started working after selecting “Any Word”… likely because I opened the test project and wasn’t watching for that).

GoMach : Perhaps you didn’t notice, but Dropbox also has some limitations against using it to save your projects. Go up one level with the link Amickie gave you and you will find articles about the main cloud sharing services and L&L’s recommendation for each.

If you’re going to use a cloud service, we actually recommend Dropbox. It’s best equipped to handle Scrivener’s package file format, and it’s the only cloud service you can use to sync with Scrivener for iOS, if that’s something you’re interested in doing.

Try using the File > Save and Rebuild Search Indexes menu option. Then close the project and reopen it. Does that fix it?

Thanks BClarke. I’m using it only on one device right now. However, I’m very aware of sync issues and did read this article
(i.e. “Using Scrivener with Cloud-sync Services” AND the section “Sharing a Project Between Computers…”), Admittedly, it’s sometimes easy to miss a point. For me, having it on a shared service is important.

Ah, thanks. No, it didn’t fix it. Ugh. I wish it did.
So I immediately opened the test project, closed it, and it works again. This old C++ programmer doesn’t understand why yet, but, as crazy as it sounds, it DOES work… consistently over MANY tries. I’m very glad you told me to try it on a new test project… that led to this discovery.

There is some connection between the running Scrivener projects. Somehow, the simple setup of running the test project is affecting the actions of my regular project. (My regular project begins working when the test project is OPENED… closing makes no difference… so I open regular, open test, close test, then begin working for the day.)

Hi all… just an update. The workaround above continues to work EVERY SINGLE TIME. This is likely a good programming clue, for what it’s worth.

Warning: nonsense coming in case programmers want a laugh: I suspect my project is improperly setting some value that all projects share. The newly created simple test project changes that value to what it should be. Thus it always works now with only the minor inconvenience of opening and closing that test project. The two projects DO interact in some way.

Windows Version: 2.9.9.9 Beta (1017011) 64-bit - 14 Aug 2020

I’m experiencing the exact same bug with a nasty twist.

Searching Next will get me to the second document (the first occurrence of the searched word) in the scrivening, but no further. Previous will find the searched word as expected despite the Not Found popup displaying every time. However, if I then try Next again it CTD.

File->Save and Index search didn’t help.

My draft is 148k words.

skribe

GoMach, I think this may be related to the other scrivenings mode situation we noted with the arrow keys in the HiDPI version. Find works perfectly well here in the non-HiDPI version. I haven’t tried it in the HiDPI version yet - don’t have access to my Surface Pro right at the moment.

Same with me, Scrivenings Find works fine on non-HiDPI RC9.

Sorry to hear that Skribe. TRY STARTING A NEW PROJECT with just one or two files (mine has two with only 1 or 2 lines in each). When I open that and close it immediately, my find works well. I want to see if yours does too.

Hi @Jestar, and @JimRac,

Thanks for looking at this. THIS STARTED with the other version. I ONLY loaded HiDPI because I had this problem and was hoping it would fix it. But it didn’t. So you will almost surely not have this issue in HiDPI version either. I have it in BOTH versions.

I hope that L&L keeps in mind that opening a simple test project (with just two tiny files) and closing instantly ALWAYS causes the right search behavior in my original project. ALWAYS! To me, that is the best clue so far because the two projects are interacting in some way (shared memory? common process parent? I’m not sure.) Note: If I close both projects and reopen my old project, the problem is back, every time. I only need to open and close the test project again to remove the problem.

My video (link in a prior post) shows that test file, but what you do NOT see is that I do this EVERY SINGLE DAY to get my searches to work. It’s never failed. There IS a relationship unless I’m the luckiest guy in the world (and I assure you that I am not. hahaha).

I’m sure they will. But to debug the problem, first they need to be able to recreate it. Do you have a project that consistently exhibits the problem, that you can zip and upload here?

Good point. The link below is a zip file with two small projects in it:

  • ScriveningsTest.scriv
  • test.scriv

I’ll be interested to hear how to works for others. Here’s what to do:

  1. Open ScriveningsTest (it may open in Scrivenings mode, but if not, put it in scrivenings mode… could click on the folder Act 1)
  2. Do a search for the word test. It should search all three files, but I’m guessing it will only search the first.
  3. Open the project called test. You dont’ have to do anything and could close test. The search may begin working across documents once that test project has been opened.
  4. Close them both, then open ScriveningsTest again, and the search will not cross document boundaries again (until you open test, or presumably any other project)

LINK to the 2 projects: dropbox.com/s/gjnaojriot8wo … v.zip?dl=0

Hi GoMach,

Good news, it doesn’t work! :smiling_imp:

Yeah, the Find operation fails for me just like you’re experiencing, and opening the second project ‘fixes’ it.

In my other projects Find still works correctly. There must be something specific about the failing project that causes this, but now that you’ve supplied a good test project, L&L should be able to recreate and figure it out.

I’m on RC9, Non-HiDPI.

ETA: If I drag and drop your Act 1 folder into my Tutorial project, then Find in the Tutorial project will also break in the same way, when in Scrivenings mode. Even though the Tutorial project was fine beforehand. Very interesting.

Best,
Jim