[LH467|Suggestion] Beta 16: Small problems with footnotes

I’m an academic writer, so my documents are usually long and have lots of footnotes. (They’re also usally boring, but I don’t expect Scrivener to fix that :smiley:) My first footnote problem occurs as soon as the inspector window is full of footnotes, as in this screenshot:


– as you can see, there are already more footnotes than can be displayed in the right-most window. When I add a new one, the list in the window doesn’t scroll, so the new footnote is hidden:

However, as soon as I paste the relevant reference into the new, blank footnote, the list scrolls and I can now see it:

Until I realised what was happening, I kept adding multiple, blank footnotes, thinking that the “Add footnote” command simply hadn’t worked.

I realise this is a small thing, but if there’s an easy fix, I’d be very grateful.

Also (while I’m riding my footnoting hobby horse):

  • Please can we have shortcuts for common inspector commands (like “Add Footnote”): none of these appear in “Options | Keyboard”, so you can’t assign custom shortcuts to them?

  • And please could existing shortcuts (like Ctrl-Shift-V, for paste and match style, etc.) work in the Inspector? It’s a real pain having to mouse over to menus and icons every time you want to, for example, italicise a word in a footnote.

Many thanks.

The issue with new comments not being shown in the inspector has been filed.

I’ve marked this thread for us to look at your suggestion of shortcuts for new comments/footnotes

The default shortcut for paste and match style works for me in Beta 16. Is it still not functioning for you?

Thanks!

Just tried the default shortcuts and they are working! Thanks. They definitely hadn’t been in earlier betas, so perhaps I just forget to re-test with beta 16. Thanks for filing the issue and for considering the shortcut possibility.

Just retesting this in B17 and realised why I thought it wasn’t working before. When you click the “cf” button in the inspector, the new footnote window doesn’t immediately have focus, even though it’s highlighted (so it looks as if it has focus). So, if you click “cf”, then hit Ctrl-Shift-V, nothing happens. You have to actually click in the new footnote box then paste. This is both unintuitive and a pain; the whole point of keyboard shortcuts, imho, is to help you keep your fingers on the keyboard.

Thanks.

A quick update on previous comments (retesting with Beta 18).

The problem of new notes/comments not being visible when you add a new one is still present. If there are lots of entries in the Inspector panel, it doesn’t automatically scroll to show the new blank note.

The problem with unformatted paste (Ctrl-Shift-V) not being usable is still there. Whether or not the newly inserted note or comment is visible, it doesn’t automatically get focus – so if you add a note and hit Ctrl-Shift-V, nothing happens. You have to use the mouse to click in the new note before you can paste. When I’m writing, I like to keep my hands on the keyboard at all times, so this is a bit of a pain.

Finally, there’s a long-standing problem that the text in the Inspector panel doesn’t reflow properly as you adjust the panel’s width. Here are a few of the notes in my current chapter:

The Inspector is too wide and is taking up too much space, so I make it narrower:

As you can see, the most recently added note has lots of useless space below it (but there are no trailing hard returns, spaces or anything else – I double checked). And notes with lots of text are now clipped on their right edge, instead of reflowing, which also means that the little “x” you use to delete a footnote – which shows in the note’s right-hand corner – has gone. To delete a note, I have to make the Inspector panel wider again.

Please could these problems be fixed in the final, shipping version?

Many thanks.

I’ve been testing some of these, since I use footnotes in my writing. For the “no hotkey exists” issue you mention, shift + f5 is the default “cf” key shortcut, and can be customized in the menu under “footnote”, unless I’m misunderstanding your intention. However, it still presents with the same bug you describe (well, not quite, I have slightly different results, but I think it’s what you’re referring to). Does this solve the missing hotkey issue from your original post at least?

I’m going to make 2 separate posts for the 2 additional footnote issues I could reproduce that aren’t already in their ticket system, they might get more developer traction than wading through a longer post. (But don’t misunderstand, I admire your thoroughness and including of screenshots!)

-eric

Did some testing of these issues, and I find multiple problems.

  1. When I create a footnote, focus does not always switch to the footnote text. Sometimes it does, sometimes it doesn’t.
  2. If I click on the footnote space, focus does not always shift to the footnote text. When it does, Ctrl-shift-V (paste and match style) may not work unless you double-click in the footnote first.
  3. If I double-click on the footnote space, focus shifts to the footnote, and a blinking cursor appears, but Ctrl-shift-V may not work. It’s like the focus is only partial.
  4. If I triple-click on the footnote space, Ctrl-shift-V will likely work.
  5. If I double-click TWICE (yeah. Quadruple-click), Ctrl-shift-V seems to work every time.

All of these seem to be related to how many times I’ve created footnotes recently (not sure of the time interval; but after creating several footnotes, item #1 went away).

More data later.

Since it’s been a while since this has been discussed and I stumbled across the same problem:

When I add a new footnote at the end of a text with a long (longer than my window displays) list of footnotes, not only does the list not scroll down to that place in the list to display the footnote (as mentioned above), for me if the list was previously focused on the footnote above that, it will then jump to the top of the list when I add the next one. Scrolling down manually for each new footnote adds up to a lot of time!