[LH4768] [RC12] Selecting Top Hierarchy in Binder Doesn't Show Screenplay Pages

If I select the top hierarchy in my binder the screenplay pages do not show up in the edit window. In the enclosed screenshot, only the folder text shows up. It appears the latest version broke some scriptwriting features.

Version: 12.9.9.12 Beta 64bit.

Sorry monsterzero, but I could not reproduce the problem.

  1. Could you please try resizing the Scrivenings editor area.

  2. Please, toggle the menu options “View > Show Titles in Scrivenings” and/or “View > Only Scrivenings Titles for Folders”.

  3. Try changing your Scrivenings separators style via File > Options > Appearance > Scrivenings > Scrivenings Separators.

  4. Also try toggling the option File > Options > > Appearance > Scrivenings > Do not show separators above titles.

  5. Does it happen only on startup, or any Scrivenings session is missing the main text editors?

Most likely some combination of options is causing the bug, but I cannot imagine any scenario that will completely remove the text editors. Any help here to reproduce the issue is highly appreciated. Thanks!

Hi,
I tried all your suggestions and non of them worked.

One interesting note, is that it’ll show the first screenplay formated scrivening in the hierarchy but nothing after that.

Also, when I click on the top “screenplay” hierarchy folder it automatically changes the edit view to “corkboard”. Which it didn’t before. Annoying, because I never used corkboard (I find the view useless with the way I work).

J

Thanks for the feedback. Do you have the problem with all projects, or only one particular project? Clicking each document shows proper text in the editor, I believe. Could you please upload some project with dummy text which misbehaves on your machine. Could you please also try the Non-HighDPI Scrivener version?

This could be some sort of settings thing that you describe above. I found that a few of my folders are acting the same way on my Mac (though not the entire script). I’ll keep digging.

Opening up the project I screenshotted above is working as (I) expected on my Mac. So it must be a global settings thing. Also, it only happens with screenwriting formated scrivenings. All other files function normally.

Keep in mind I’m used to it functioning this way since I started using Scrivener when Mac ver3 came out. So I apologize if somehow that’s not the norm—it’s just what I’m used to.

Here is a test sample that exhibits the problem described above (and more). It also doesn’t show the regular text when selecting “screenplay” in the binder.

dropbox.com/sh/tcu89xhruokx … gHlRa?dl=0

NOTE: Installing the Non-HiDPI version of RC12 actually solves the issue.

Thanks for your project, monsterzero! It revealed the problem. For some reason the paragraph spacing in your documents is not as expected for Scrivener for Windows. As a result all the text gets no spacing and gets stacked over each other. I am investigating further how to fix it and why the paragraph spacing is so weird.

Could you please share some more info about the way you created the project (under Mac, Win?). Is there something special in the spacing that you use and we fail handling properly?

Probably blindly selecting the whole text(Ctrl+A) and applying the “1.0x” paragraph spacing will make you scriptwriting text appear. Obviously try this on a copy of your project, as it might spoil your expected scriptwriting text formatting, which relies heavily on paragraph formatting.

I will check what can be done to improve and avoid this problem in the future. Thanks!

Hi monsterzero, after investigating this a little deeper the main problem is caused by the new updates in Scrivenings mode. The bug is present only inside the HighDPI version of Scrivener. Please, download the Non-HighDPI version of Scrivener from the main announcement page. We have enough info to reproduce and fix this further. Thank You!

Glad I could help!