[LH4783] Retaining Italics within Footnotes

Good morning. I’m not sure if this is a bug within the current beta. I’m admittedly rather new to the software, but have been getting the hang of it.

Issue: Footnotes in my project do not retain italics when compiled. I’ve tried compiling to pdf, rtf, doc, and docx - same issue everywhere. I’ve tried every manner of setting or workaround I can think of or google with regard to overrides and default formatting. Italics and other formatting are retained without issue in the body text.

Has anyone else experienced this or have any idea how to work around this, assuming it’s not a bug in need of a future update? My project uses a lot of footnotes within each section, and most need to retain the italics. Otherwise I’m looking at a lot of manual formatting in Word on the back end in order to fix this compile issue.

This type of formatting problems are best demonstrated with a small example project with a document or two with dummy text. Scrivener has too many options to control formatting, so it is hard to give an answer that will help you pinpoint the problem immediately.

Thank you for the reply. Shouldn’t the footnotes retain italics by design, whether overriding the font or not? I fear it may be a bug.

I am not saying that there is no bug. I request for a demo project to reproduce the bug.

Good morning. I’ve attached a demo project I threw together quickly, as well as an example of the compile output.

Thanks, 0TooL0 for your project. It helped us spot the problem. This has been filed and will be fixed in the next update.

To avoid this problem in the current build, do not specify Footnotes override font. I understand that it might cause different kind of troubles.

Great thank you!