[LH4867] RC14: formatting a List causes Scrivener to crash

I was creating a nested list in my document and was using the keyboard shortcuts to change the bullet styles and increase, decrease the indents when suddenly Scrivener completely disappeared from the screen.

I restarted it with no problem and fortunately Scrivener’s frequent save functions meant that no work was lost. So I carried on with using Meta + Alt + right arrow to increase the indent of the nested part of the list and then Meta + > to apply a different bullet style. Scriv disappeared again, no warning, no signs of lockup or anything. Just complete dissappearance.

This has happened three times this evening but I haven’t yet succeeded to find exactly which combination of keystrokes is guaranteed to reproduce the crash.

[For my non-fiction writing, lists are often useful and sometimes it helps to nest them. Without this formatting, a lot of the sense is lost.]

EDIT: I added a new line to the nested list, Meta+Alt+left to shift the margin to the non-nested level, Meta+< to change bullet but this changed the nested ones as well so I did Meta+> to go back to how it was. This caused Scrivener to disappear.
I restarted and repeated the above actions with the same result.

I know that quite often on Windows, another day and a fresh reboot gets rid of problems - but NOT on this one.

Today, three successive applications of ‘next list style’ using meta+> causes Scrivener to close down abruptly with no warning. Other combinations of meta+> and meta+< produce the same result.

Same crash happens when using successive ( 4 or 5) applications of the mouse clicking on Format > List > Next List Style. So it is not a keyboard shortcut problem.

My Windows box is a new desktop machine (in October 2020), AMD Ryzen 5 3600, 32GB RAM, with a new fresh installation of Windows 10 Pro (currently on 20H2 with all current updates MS has felt fit to pass my way). So I would hope it should be fit for purpose.

.

Have you tried uninstalling and re-installing the beta?

IIRC, the default installation is the Hi-DPI version now – have you tried downloading and installing the Lo-DPI version? It uses an older version of one of the system libraries, and if you don’t get it to crash there that helps the devs isolate where the problem is coming from.

Thanks for the suggestion. I checked first that the crash still occurs in my default installation (which is Hi-DPI since RC13) and it does.
Then I uninstalled Scrivener and downloaded the Lo-DPI. The crash also occurrs in the Lo-DPI version of RC14.

[As an aside, I wished I hadn’t interfered with the installation. My Scrivener entry in the Start Menu doesn’t work now - it just opens \AppData\Local\Scrivener\Scrivener\ in file explorer instead of launching
\AppData\Local\Scrivener\Scrivener.exe. I had to install a second time and accept the offer of an icon on the desktop. And I don’t like icons on the desktop.]

You should be able to navigate to the Scrivener.exe file in Windows Explorer and right-click it, then select “Pin to Start” to fix that.

Thanks for the advice. I’m not too well up on Windows and I didn’t know about ‘Pin to Start’ but I did a full reinstall from the admin account and that fixed it.

Same crash in RC15

This has been fixed and will be available in RC17. Thanks!