[LH4928] <$custom:> broken in 2.9.9.18?

I had been successfully compiling using custom metadata for the last few months, but suddenly I’m seeing the document title being displayed for every metadata entry, regardless of what I specified.

My custom metadata insert in the compile options:

[attachment=1]1.JPG[/attachment]

How it looks in the PDF:

[attachment=0]2.JPG[/attachment]

Previously this worked, and I would actually print the specified metadata in the PDF. The reason I’m not using the actual “Metadata” checkbox in the compile settings is that I don’t want to print Date created, Writing Status, etc. I want to keep it clean and only display the metadata relevant to the reader

Same issue in: Version: 2.9.9.19 Beta (1214272) 64-bit - 27 Feb 2021

In my case:

Chapter <$n>
<$custom:ChapTitle>

…just spits out the Title, which is inconvenient.

Thanks for the report! I’ve got this on the bug list. A workaround, at least for the first post, would be to put the metadata tag in the compile layout’s “Prefix” pane and tick the box to put the prefix after the title. That at least avoids the bug of the document title being used for the replacement when the tag is in the title prefix/suffix.

This has been fixed and will be available in the next update RC20. Thanks!

Thanks that’s brilliant.