Line numbering runs out at 99

Trying to use the paragraph numbering option to give each line of a transcript a number so I can find sections easily. (Am using Scrivener in a slightly lateral way for transcript analysis). However I find numbering only goes to 99 then restarts. Can Scrivener have three digit numbers? (Or even four digit?)

I can’t reproduce this. To test it, I loaded up the tutorial project, selected Part I in the Binder, turned on Scrivenings, and then enabled line numbering. I am able to see 175 paragraphs in this section of the tutorial; the roll-over from 99 to 100 is normal. If anything, I would guess by the amount of available space, that it might run into problems at 1,000 paragraphs—but that would be a very unusual quantity to encounter in a Scrivener context. I also tested in one long document, by copying and pasting the Part I Scrivenings session into a text file, with the same result.

Hmm. How did I do it?
I started a new project because I wanted one just for transcript analysis, given the number of transcripts I had.
I pasted a transcript out of a previous project where I had started on the analysis idea and then thought it would get too big and messy if left in the main project. It was pasted into its own Scrivener document in the “Research” folder. Then I selected the whole transcript and clicked the “list” icon in the taskbar and chose the 1,2,3 numbering. Then I scrolled through the transcript and was really happy until I found the problem.

I tried to paste an example into this reply but the numbering would not paste.

Hope this helps

Ah ha, I see what you are talking about now (sorry, I was using a different feature and a different platform; must be late). Nevertheless, if I take the long document and select the whole thing with Ctrl-A; then use 1.2.3. list format, I get numbers that go past 100. Hmm.

What happens if you put your cursor on the end of line 95 and press return (to insert a new numbered line?) What is the word count in this file? Perhaps it is way bigger than mine.

Something still might be off though, because when I select some paragraphs out of this I can paste the numbers.

Its getting weirder.
1 The not pasting thing.
I double checked this by pasting into Word and it worked fine. The numbers were visible. It must have been the form field for comments to this forum that did not display them when I tried to paste to it.

  1. Testing by renumbering
    I tried a second bit of transcription text, but used the same sequence - ie, pasting from one Scrivener project to another then adding numbers. This time it worked. There are only two differences that I can discern. First, I made a slight mistake in the one that worked by clicking “list” so it dot pointed them before I changed to numbering. This should not have made a difference however. My guess is that it might be associated with other formatting.

The only other difference is that the first “99” to “00” document was in Calibri font with double spacing between the lines as the style. The one that worked was in Verdana and single spaced. The document length was also different. The first faulty one was 11,398 words. The second successful one was 6,335 words.

I tried adding a return to the faulty one near 99 as you suggested, but it maintained 99 and just moved the corresponding line down to 00.

Good on you if you can glean anything out of this. I’m mystified.

Any chance that your indent is overhanging the edge and you’re just not seeing the “1” in “100”? I know it sounds silly, but since the numbering from the beginning doesn’t display lead 0s, it’s odd that you’re seeing them here, and since you pasted the text in you might’ve brought over the ruler formatting without realizing. You can display the ruler at the top of the editor by choosing Format>Show Ruler and then try selecting the text and dragging the indents around to see if it fixes the issue.

Ah ha! You cracked it! Well done you, and I feel dumb! :smiley:
However, its not the first time I have had a problem with things going beyond the margin. It would be quite useful if Scrivener had a virtual margin like Word, (adjustable of course for those who value screen real estate) so you could see more easily if things go wrong.
Thanks heaps for the advice though. Will now get back to strange analytic activities using Scrivener for purposes for which it was not designed.

You can adjust the margin in Tools>Options… under the Editor tab; the last option on the right under “Editor Options” will set the margins. Currently this affects all four margins, so you might want to set it high temporarily to see your overhang and adjust it in the editor and then lower it again to avoid having a large margin at the top and bottom of your editor. A future update will allow you to set the sides and top and bottom separately.

That half worked. I had another problem where the top line had run off the visible margin in several places. I adjusted the margin in Tools> Options.Editor as you suggested and Scrivener applied that ok. Then when I grabbed the top tab indicator on the ruler to drag it back to actually being on the beginning of the white section of the ruler, Scrivener crashed.

Forgot to say, I had done a “select all” (Ctrl A) before adjusting the ruler tab.

Was your crash in 029 or an earlier beta? There is a bug that does cause a crash with the overhanging indent, and I don’t think it was fixed, but when I was just playing around earlier checking a sample of an overhanging indent as you might’ve gotten for the list, I wasn’t able to replicate it. I wasn’t trying particularly hard, though, and as I said, this isn’t on Lee’s list as having been fixed yet, so I probably just didn’t trigger it properly. You might get around it by selecting just part of the text and not doing a Select All, but otherwise if you’re still having issues you might do better to re-import the text after adjusting the indents in another processor, until this problem is corrected.

It was 0.0.29. I tried (after recovering, just now) resetting the margins back to something more normal in “Tools > Options > Editor” and it worked ok without crashing. It seemed to be moving the ruler tab marker that set it off originally. I don’t have a problem now with overhanging indents (if that is not a contradiction in terms). The first move (resetting margins in “tools”) fixed it. But I was just making sure the ruler knew where the tab should have been.