Line spacing in Screenplay Character Area

How do I change the line spacing in Screenplay format of a character?

It sounds like you’re looking for Format > Scriptwriting > Script Settings. You can adjust the Spacing under the Paragraph tab for the Character element. Note that with the Screenplay format, there is a Fixed Line Height setting in the Options… pane (the small Options… button is near the lower right-hand corner of the window). You need to first set the fixed line height to 0pt before the Spacing setting will have any effect.