Links Not Exporting Properly To Kindle

I have a strange problem. I created what appears to be a working Table of Contents by copying and pasting Scrivener Links into a file called Contents.

It functions perfectly within Scrivener and when I export to Kindle it appears (on the surface) to be a working Table of Contents. But, there are a few glitches…

  1. When I test it on Kindle, every link leads to the following chapter! For example, my first 3 links are like this:

-About The Authors
-About This Book

If I click on ‘about the authors’ I am taken to ‘about this book’. ‘About this book’ leads to contributors, etc…

I have checked and I am definitely clicking on the right place. When I go line by line down the page and click on the very first clickable spot (About The Authors) I am taken to the following chapter. I first noticed this strange behaviour in the ToC but later checked and the same thing happens for every internal link in the kindle file.

Also, for some reason the last chapter in the book doesn’t want to be linked in Kindle. It’s been copied as a Scrivener link like everything else in the TOC and all the compile settings are the same. I even deleted and relinked it to be sure.

Any ideas?


Are the different chapters separated properly by section breaks? Links will only take you to the start of a new HTML file - a new chapter, so there must be a proper section break between each chapter (as set in “Separators”).

All the best,

This is how it’s currently set:

I think that’s what you mean? I have section breaks selected for every possible spot.

Hmm, yes, that looks fine. And do all the chapters have titles? (That shouldn’t affect things, but might.) Could you send the project to us (zipped up) at support AT literatureandlatte DOT com so we can take a look at what’s going on?

Thanks and all the best,

I did another test…

If I create a ToC using only the Kindle Compile tool, all the links work correctly (both in the ToC and throughout the document).

It’s only when I create a ToC by copying my docs as Scrivener Links into a file called ‘Contents’ that this problem occurs. I wanted to do it that way, so that I could format the ToC better (add sub headings, etc…)