Links Work in MOBI format, But Not EPUB

Hello all,

I’m at my wit’s end with this problem. It makes no sense to me. I have links built at the end of my book for reviews and the one for PINTREST works perfect in MOBI format. But in EPUB, it gets weird.

When in Calibre, I click on the link in the EPUB, it works just dandy. I can take the link and cut and paste it right into the browser and it works like a charm. If I click on it within Scrivener itself…no problem. Woosh…right to the correct page.

BUT…when I try it in any EPUB device, it will not work. The pic of the bookcover doesn’t appear and it doesn’t show any words or title. Like it goes to the site, but then stalls. And if you try and pin it, it refuses to go anywhere. It comes up with this error message…

Parameter ‘image_url’ (value http:null) is not a valid URL format.

Again, exact same link works perfectly in MOBI and in calibre (both formats), but anything in reader designed for EPUBS I have, it won’t work at all.

How is that possible? Same link, same address.

HELP!!! I’m going crazy here.

Thanks in advance.

edited to add

Just discovered it DOES work in the Universal Book Reader in my Android Phone. It’s for EPUBS. Now I’m even more confused.

What readers is it not working on?

All the best,

It doesn’t work in Adobe Digital Editions. But none of them do, so I think my reader is just bad, or that choice is somehow turned off. But I’ve tried it on Google Play and it won’t come up. Interestingly enough, it is now working on Nook Books where it didn’t before.

Go figure.

I don’t get it what’s going on, but am wondering if it’s something I should keep stressing about or not.

Strange. I’ve never had a problem with links in Adobe Digital Editions on the Mac. What about in iBooks, do the links work there? The strange thing is that the underlying HTML is exactly the same whether you are creating an .epub or .mobi file.

I know. That’s what has me so baffled. I’m not an expert in html at all, so I just do what I can. Thing is, though the mobi is okay, something must be wrong with the epub format. I just tried to upload it to NOOK, and while it will upload, I can’t see anything in the editor. So can’t preview. Not good.

sigh It’s one of those days, you know?