Linux user thread

Ok, I must have completely bungled that in my head. I think it would be nice to have a way to export a Mac 2.x project out as one that could be opened in Mac 1.54. I’m gonna have to figure out a way to keep this as a file I can still do something with after the betas/trials expire…

Josh

If you have no intention to upgrade to 2.0, you’ll want to treat the trial in the same way you would have you had no intention of using Scrivener. At the end of the trial, use Compile and File/Export/Files… to get everything out of the project(s). Then in your case, you’ll want to just drag that stuff into a fresh Scrivener 1.54 project.

But, if you step back to 1.54, you’ll lose the ability to keep your projects floating between the Mac and your Linux system. So that is something to consider.

The beta expiration date will be reset with a new release before it expires. Nobody will left hanging without a binary they can use to access their work.

I’ve given serious thought to making the switch to Linux for a while. It’s mainly that I have a license for 1.54, so I would be able to keep the project in a manageable, editable form. I just want to keep my options open for any decisions I make in the future.

Josh

It worked!

Little tutorial for amd64 users to enable spell ckeck:

  1. install libaspell15 and libaspell-dev (amd64)
  2. manually extract the content of libaspell15 i386, than replace the libaspell* (amd64) from /usr/lib with the i386 ones (libaspell.so.15.1.4, libaspell.so.15 and the sym links)

Thanks dday376. GDebi did the trick and now I have a working version of Scrivener on Linux!

considering all that I’ve caught up with, i should update the package to incl. libaspell-dev for i386 scrivener. Subsequently, I’ve referenced the issue on 64bit and it should be resolved according to this thread in the easiest manner using getlibs. should be something on the order of ‘getlibs -i libaspell-dev’ or something like that. in the future, i suppose i could add some sort of postinstallation step in the installation to do this automatically. Regardless, I will update the packages soon…

Hi everyone.

I am easily able to install the beta-2-all package on Linux Mint 10 AMD64 but GDebi won’t let me install the i386 version.

sudo dpkg -i scrivener-beta_1.3beta-4_i386.deb dpkg: error processing scrivener-beta_1.3beta-4_i386.deb (--install): package architecture (i386) does not match system (amd64) Errors were encountered while processing: scrivener-beta_1.3beta-4_i386.deb

I suggest you rename, at least for the ubuntu based versions, the .deb as “all”.

Chris

PS. Did a rename. Did not work. I think we do need a 64 bit version, sorry – and (of course) the old beta is past its use by date.

Well, here we go again, with aspell all fixed up for i386!

scrivener-beta_1.3beta5_i386.deb
scrivener-beta-1.3beta-6.i386.rpm
scrivener-beta-1.3beta5.tgz

for you amd64 guys (which amazes me how many of you there are!) it should be relatively easy to get libaspell-dev for i386 to install on your system. as far as i can tell, ubuntu64 doesn’t give you guys an easy (apt-get) way to get it; but, if you refer to the link i gave in my previous post, it should be pretty easy to get that library following those instructions ^^

note: installing this package with dpkg will result in an error. specifically, dpkg will tell you that it can’t be installed because libaspell-dev is not installed. dpkg is not as intelligent as apt, which means you have to actually install it separately. if, and when, i repository-ize this, probably through dropbox somehow, apt-get should resolve that :wink:… regardless, before, or after, you attempt to install scrivener, just install libaspell-dev and it will finish ( or be prepared to) install scrivener.

Thus, on Ubuntu/Debian, installing is still as easy as:

$ sudo apt-get install libaspell-dev $ sudo dpkg -i scrivener-beta_1.3beta5_i386.deb

@pukeko: Yeah, I’ve been stewing over packaging scrivener for amd64. Reluctantly, though, if I set it for all architectures, the dependencies get all screwed up; amd64 and i386 have different requirements. Furthermore, scrivener was never compiled for 64 bit, so the problem gets a little hairier. You see, I (we) can’t compile scrivener because LiteratureAndLatte only provides pre-compiled binaries.

The only way Scrivener can work on AMD64 is thanks to the ia32-libs package on Ubuntu and the magical 32 bit compatibility mode on Intel/AMD 64 bit processors.

Thus, until I can figure it out (or, more specifically, put some time into it) the easiest way to install Scrivener is just to force-install the darn thing. Then, get libaspell-dev for i386 installed accordingly if you want spell-check (previously covered).

$ sudo dpkg -i --force-architecture,depends scrivener-beta_1.3beta-5_386.deb

So we have to replace our 64 bit aspell with the 32 bit version?

Won’t that break aspell for all the 64 bit applications that use it?

If that’s the case it’d be better just to use the windows version through wine. Breaking linux for one program isn’t worth it…

No, you’re not replacing the 64-bit aspell with the 32-bit version. You need to have the 64-bit version installed, and you need to add the 32-bit libraries. See my original original post. The files you add will go in either Scrivener’s lib directory, or /usr/lib32, safely away from interfering with the native 64-bit libaspell files.

Ah, ok. Will try…

I’m starting to see multiple ways to do things on this thread, most notably on how to get 32-bit aspell on a 64-bit system, and I think we need to start putting this all in a single document somewhere. I actually wrote a post on my blog about this, but @randywallace already released new packages so my post is outdated.

I found this page on L&L’s wiki (started by @randywallace). I’ll find some time today to put what I can from our posts on there, and maybe @randywallace can maintain links to his packages there as well?

It woooooooooooooooooooooooooooooooooooooooorked!

Huzzah!

Thank you so much. You are now officially my hero.

OK, the next thing to figure out is how to modify the aspell vocabulary list. Scrivener is underlining a number of words that are spelled correctly. It also includes those words in its list of possible spellings when you right-click on them. However, when you select the word the underline does not disappear. I have to tell it to Learn the word in order for it to stop marking it as misspelled.

OH, heh, that wikipage is technically un-useable due to something LAP said a while ago about ‘finding somewhere else to talk about Scrivener on Linux’ or something like that… so I stopped maintaining that wiki page :wink:

:confused: Er - whoops. Should I strip it back down?

To be honest, I’d recently decided not to upgrade Scrivener to version 2 because it wasn’t interoperable enough for me. I use all platforms – mainly Linux, and sometimes Windows and Mac.

So I was planning on dropping by here to leave a sad note that though Scrivener really looked interesting, I couldn’t justify locking myself to a platform I didn’t use all that often.

Then I discovered the Linux port. I slapped it on my main partition, Arch 64 running Xfce, and it seems to work out of the box. It looks very promising, and I upgraded to version 2 on my MacBook. (I assume that this will apply to the commercial Linux version when that day comes.)

Now I have to learn how to use Scrivener, which I never really did before. I played around a bit a couple years ago, but when I realized that the Apple software lockin was too oppressive, I bailed. I took the tutorial from the Mac, but it doesn’t work on Linux. I need the tutorial now … do I really have to install the Windows port to get it working on Linux?

I can do that, but it is a bit of a pain.

ETA: Okay, I’ve confirmed that the Windows tutorial does work but the Mac one does not … that’s worth mentioning. I tried a Wine install of the Windows port – it ended up borked, but I did get the tutorial.

Scrivener for Linux was mentioned today on omgubuntu http://www.omgubuntu.co.uk/2010/11/scrivener-for-linux-ubuntu-download-deb/

heh, omg, omgubuntu caused dropbox to disable public access to my public folder! oh noes! now i have to fix this ^^