List style

  1. How can I make a shortcut for list style?
  2. When I use the list style Im having this problem:

This is my list:
one
two
three

When I apply the style I get this:

one
2.
two
3.
three

Instead of:

  1. one
  2. two
  3. three

any help?

  1. Unfortunately, not really. There is not system for stylesheets in the software. We do have Formatting Presets, which can apply a set of settings to some text, like a macro. However, the underlying system that we use for the text engine doesn’t “see” list formatting as a type of formatting, so it doesn’t get saved into the preset. Otherwise, that would be a way of giving one a shortcut. Make a preset and then give the preset a shortcut. You can give some of the list options a shortcut. From what I can tell, only the bullets work. If you give the bullet character a shortcut for instance, it’ll work. It for some reason does not work with “1. 2. 3.” or any of the enumerated list types. Something about those menu names don’t work like normal menu names. Perhaps they are generated on the fly.
  2. As for the second problem, that looks as though your ruler isn’t getting set right by the tool. OS X inserts a tab, then the list marker, a second tab, and then your text. If the ruler doesn’t have more than one tab set up, then the second one will run over to a second line (that’s just a quirk of the system). However when you use the Format/List/ sub-menu to apply list settings to a sequence of lines, it should be overriding whatever ruler settings those lines had. The only possibility I can think of is that this text wasn’t typed into Scrivener originally, and some formatting gremlins crept in from the paste. Do you get the same result if you type in four lines in a blank document, and then select them all and apply a list type?

AmberV, thank for you response. The problem is the same when I type directly. I had first to select none, and then apply the list style in order to work.

Were the lists pasted in from another word processor originally? If so they might need to be reformatted like you describe. Selecting None and then resetting the type is one way of doing that. Sometimes right-clicking in the list and choosing “Re-number List” from the top of the contextual menu can help.