Loading old files

I have latest version, and loaded it onto my desktop computer as well as my laptop, so I can be sure of having backups. But, I tried to load files to my desktop, it said it was created in an older version, so automatically made an archive of the book. But then I could open neither of them. I think, though the version on desktop is now 1.02, while laptop is 1.11 (that is the latest, isn’t it?). Maybe I have an older scrivener uploaded to my desk machine.

In any case, I can’t open older docs on either version. I just get a blank file, which scares me a bit.

There was a bad bug in versions prior to 1.10 that could cause problems if you tried to open a newer version in them. If you tried to open a 1.1x project in 1.02 or 1.03, 1.02/3 wouldn’t complain that it couldn’t open it and would instead corrupt the file. So you may have done this. The good news is that it backs up before converting, so one of the automatic backups that were created should still work - you just need to go through the backups.
All the best,