Look Up doesn’t work anymore

It just flashes for a brief second and vanishes. Using Scrivener 1.2.2, running iOS 15.5. Have rebooted iPad Mini multiple times. Any help appreciated.

More details: Look Up works fine in Apple Notes. It doesn’t work in any Scrivener projects.

1 Like

You’re right. It doesn’t work for me either.

Thanks for confirming. Ack! Hopefully a support person will see this. I am praying my iPadPro hasn’t updated iOS yet. I need that two-hour train commute time to edit every day.

1 Like

@drking, are you using the same device (iPad) and iOS version (15.5)? I’m not reproducing this on the iPad I have available for testing at the moment, but it’s still running 14.6, so this may be an issue only on newer systems.

I am using 15.5 on iPad Pro

on 15.5 and an iPad Air 4, the first time I tried it on Scrivener (I use it all the time elsewhere, but not so far here…), it indeed didn’t work – nothing was presented.

But the second time, and all thereafter, quite a few to try it, Lookup worked fine, in the normal ways.

I wonder if it’s something of a cache or such that needed to be cleared between the recent release and the iOS Scrivener we’ve been using before last week?

I even have things like Norton installed, which probably get in the chain of events for the web connections, as it tries to fend off advertisements.

I hope so. That would be an easy fix, right?

This morning I managed to stop my iPad Pro from updating to 15.5 just in time.

My iPad Pro is running iOS 15.3.1 and Scrivener 1.2.1 and does not have the problem.

So now we’re looking at either (1) 15.5 or (2) 1.2.2 is the problem?

Weekend troubleshooting ‘r’ us!

Trying it again this morning (!) Lookup seems very solid running both…also trying it in Research docs as well as Draft/Manuscript…

Testing for isolation can be such fun :upside_down_face:

have to smile for us all :slight_smile:

I wonder if either of you have tried the good old full power-down, power-up, set things to rights step on your iPads?

This is needed occasionally even with Apple, if not as direly as with Windows.

Here, without the ‘force’ part:

https://support.apple.com/en-us/HT210631

I am using 15.5 on iPad Pro and 1.2.2 (3211) on Scrivener.

Yes I’ve already tried force start several times.

I might have worded that better – I meant not to use the force option.

Reason – after some months testing 14.x betas, I had another reason to do a full factory reset (make like originally delivered) and reload from backup.

In this, I regained more than 50GB of storage space. That’s a huge amount, and I have adequate suspicions it mounted to this value due to a number of forced restarts I did during the beta.

There are, one might add, technical reasons why this might well be so.

1 Like

OK, just tried that. No change; does not fix the problem. And I’ve already done the force restart 5x.

1 Like

This has been filed to the bug list. In my testing, the main trigger is whether or not you’re using an external keyboard. I couldn’t find anything else that had any impact on it, but if someone else does find something conclusive that can trigger it happening 100% of the time, and 0% without that condition, it would be appreciated.

1 Like

That’s really good detective work, @AmberV – and I think I can verify that you found it :herb:

On my iPad Air 4 with latest released iPadOS, 15.5 if I am not looking at it:

  • Magic Keyboard on, as most times: Lookup works its magic consistently
  • bare iPad, either screen keyboard size, immediately and consistently Lookup appears only for the beat of a magician’s wand, and then thoroughly disappears.

Momentary appearance might possibly be a clue for the tech team in where this problem is arising, might not…

1 Like

I can also verify to that it happens without using an external keyboard. I only use the bare iPad keyboard. When I highlight a word and choose look up, the window for the look up flashes quickly then disappears.

Hi AmberV. Thanks for adding this to the bug list. I did some more testing today. I have two iPads: an iPad Pro (the huge one), that I do most of my editing on, and an iPad Mini.

Today, on the iPad Mini, which is running iOS 15.5, and on which I first noticed this problem, I deleted the Scrivener app and all associated files. I then rebooted the iPad Mini. I then went to the App Store and downloaded a fresh copy of Scrivener. After connecting to Dropbox, Scrivener downloaded my current project. I then tested the issue. No change. Identical problem with the Dictionary panel briefly flashing and then vanishing.

The iPad Mini does not accept an integrated keyboard that it drops into, like the larger iPads, so I technically have never attached it to a keyboard. However, for testing’s sake, I purloined my BT keyboard from my iMac setup and connected it in Settings to the iPad Mini. Then I opened Scrivener. To my surprise, with the BT keyboard connected and active, the Dictionary feature sprang back to life: double tap a word, tap Look Up on the pop-up panel, and the Dictionary panel came up, with the definition, and stayed put. However, the instant I turned off the hardware keyboard, the feature stopped working and returned to the problematic behavior I’d had on the iPad Mini ever since I upgraded to iOS 15.5. As a further test, I downloaded and installed 15.6 on the iPad Mini. That did not fix the problem.

In my mind, the fact that the Dictionary will work when an external keyboard is connected is a bit of a red herring, as the main argument for using iPads is their smaller form factor in comparison to a laptop. Yes, it does provide potential information that might help troubleshooting, but it seems inaccurate to frame the problem as “oh, this happens when a keyboard is not attached.” Many iPad users never use an external keyboard; and reinforcing that point, the product does not ship with a hardware keyboard.

This issue continues to remain a very concerning problem for me because I use my iPad Pro every day for heavy editing on a novel that I’ve been working on (in Scrivener) for roughly eight years. Because of this problem, I can no longer upgrade my iPad Pro’s iOS, lest I lose this feature. My novel and editing process are far more important than my iPad Pro, so for now I must leave the iOS version frozen at 15.3.1. It is not even helpful that I am almost finished with my first draft, as I have five other books in the series to write after this one is done. Scrivener is my workhorse—I wouldn’t be able to work without it—so when an onerous technical problem arises, I have to stay on top of it. Small issues (like what, in my opinion, is a rather poor implementation of a Bookmarks feature) are easily accepted over time. The instant, pop-up dictionary feature that is so marvelous, however, is a critically important feature.

Any efforts your team can put toward resolving this I greatly appreciate! Thanks.

Kind of think you’d want the Apple updates for the security issues they address, so mention that for balance.

As far as dictionaries, have you learned to use the nultiwindow abilities in the iPad? They’ve gotten that much better past a point of iPadOs 14 or maybe early 15.

With those, you can:

  • split the screen to have Scrivener share with for example a web browser on dictionary, thesaurus, word graph etc. sites of any kind.
  • in split screen, you can choose proportions 50-50 or 25-75 just by sliding the divider.
  • that would let you use most writerly sites effectively and rapidly, I think, but there’s another way to have an extra window – in fact you can do this while keeping two panes open, when you like.
  • this feature is the sliding pane that will hold an app including a website in a pop-up panel that floats – and is fully movable – above your Scrivener or split main window.
  • what’s especially nice about the sliding pane is that you dan just ‘toss’ it with your finger on its fat top border, to either side. Then it will disappear except for a small tag, which lets you drag it back into view when you want to use it.

I think you have to play with these abilities a bit to get comfortable, but that’s true usually of the features of iPads – and these are particularly nice ones, I think, for any of us who like to do a lot of work on that excellent keyboard…

Hope it will work for you.

Hi folks, more troubleshooting results. Hope you see this, AmberV.

I was on the train yesterday, editing my novel on my iPad Pro, which is still at 15.3.1, when suddenly the Dictionary popup stopped working. Nothing has changed on that device; there were no updates to the iOS, no new Scrivener projects added, exact same usage patterns (sometimes keyboard connected, usually not) as for the entire previous year. So out of nowhere the problem has now hit my iPad Pro. Based on this, I no longer think the issue is iOS 15.3.1 vs 15.5. My apologies for pushing that theory.

I am very upset now over the bug, as it seriously impairs my editing process on the train. I cannot take a keyboard or use a laptop because of a medical condition, and narrsd’s recommendations for a split keyboard workaround I do not consider a viable option.

As I am nearing completion of my first draft after 8 years, I will be preparing for weeks of repeated read-throughs on the train during the remainder of August and in September in preparation for copyright submission and I would really, really like to get the Dictionary function back. Anything the L&L team can do would be greatly appreciated!!

Thanks.

Split screen options are not a solution, in my opinion. I am already using a gigantic iPad Pro for editing in order to maximize speed and ease of use; I can’t afford to split the screen and open something else up on the other side to look up a word. Apple’s Dictionary doesn’t even seem to be a native app; it’s somehow integrated into LookUp. Other issues make these type of workarounds additionally problematic for me (my iPad doesn’t not have internet connectivity—even if it did, my train ride to work is through the country, mostly off grid—and I have medical issues that make any additional physical effort in moving devices around extremely painful). Thanks for your detail, though…you provided a lot of useful content for “screen-splitting” UI and UX issues that would be really helpful, otherwise! It’s just that my editing UX has to be completely submersive (which is why the integrated dictionary was so helpful—unfortunately past tense now).