Losing chapters when trying to compile/export

Hi,

This is my first time trying to compile/export a document from Scrivener. I’ve finally finished my novel revisions but I can’t seem to manage to get my document to export correctly. I can only seem to make the entire thing to show up if I compile in Original Format. If I try to change it to novel format or make any other changes the contents of the first two chapters completely disappear in both the preview PDF and the exported copies. It still shows those chapters are selected. The text box is checked for each. I just can’t figure out how to export everything without losing formatting and having to start over in Word. I’d rather not do that, but this is making me crazy.

Please help!

It sounds like you’re probably just not compiling the text for the type or level of those first couple documents. The “Original” preset for compile includes text for all types at all levels, but the others change things up a bit, based on the project template designs. If you could post a screenshot of your binder and of your settings under the “Formatting” tab of compile (click the triangle button to the right of the “Format As” drop-down menu if you don’t see that), it would help figure this out specifically.

I’m imagining you have something like this:


In that case, the first to chapters are written directly in the folder (since folders can be both containers and documents), and since the format settings don’t include the text for folders, only the title, the contents of those chapters won’t be included in the compiled manuscript. Make sure you’ve got all the necessary boxes checked in that “text” column.

Yes! I think you’re probably right. That is exactly how it looks with the first two chapters being folders. I figured it was something simple like that that I was overlooking but I also knew I could try to pinpoint it for hours, unsuccessfully. Thanks so much! :slight_smile:

Also, is there any way to make it so the first paragraph in a new section will start flush to the left? I can’t see anything to remove that automatic indentation. I think I still have a lot to learn…

No problem! For the indentation, in that same formatting pane if you click the “Options” button in the top right corner, you’ll see a box to check to remove first paragraph indents.

Thank you, that’s very helpful! I swear I could do the tutorial a million times and I still won’t have a clue what I’m doing. These sorts of things are so difficult for my meager brain to grasp.

Now I have a new issue. I can’t save the resulting RTF file as a Word document. This time I kept it in Original format, and just clicked that button to remove first paragraph line indentations figuring that would keep it closest to the formatting I want. But when I tried to then save it as a DOCX its telling me it’s doesn’t recognize some of the characters or something like that and won’t open it. But When I tried to save the RTF file from a custom export as a Docx and then open it it worked just fine–less the first two chapters, of course…:stuck_out_tongue:

This is maddening! All I want to do is export my novel in as close to the orginal format as possible without line indents on first paragraphs and wind up with a Word Document I can tweak appropriately and send off to my editor. I can’t believe I’m finding it this hard to do that. I need an in-house Scrivener tutor, apparently. sob

Hrm, this one is stumping me. I confess I’m a bit out of my depth with most of the Word .docx stuff, so I may need a little more research. Just so I’m clear, you’re compiling to RTF in Scrivener, then opening the resulting file in Word and it won’t let you save it as a .docx at that point?

If you just need to get a file that acts like a duck and quacks like a duck and opens in Word by default, you could try exporting as .doc. By default, Scrivener uses the more powerful RTF exporter for this and just wraps it in the .doc extension so if you send it off to your editor who demands a Word file, she gets a Word file. That’s not the same for the .docx exporter, so your method is what you’d need to do to get that extension–I’m just not sure why Word wouldn’t let you save it.