Losing Footnote Text in Multi-Markdown to LaTeX Export


I am having a weird problem. I compile my Scrivener draft through Multimarkdown to LaTeX. Until a few days ago, this worked fine. But, I am now losing all the footnote text. The .tex file produced by compilation has “\footnote{}” where all the footnotes were in the Scrivener document, but the braces have no contents. The problem seems to be limited to compiling for LaTeX. If I compile for plain multimarkdown, or straight into .rtf, the footnotes and their text survive.

Can anyone help?

Thank you,


I’m moving this to the MultiMarkdown section of the forum so that one of the MMD users can hopefully help. It sounds like an MMD setting, but I’m not sufficiently knowledgeable about MMD to put you right, I’m afraid. All Scrivener does is hand the text across to MMD to do the conversion, so if the footnotes are appearing in plain MMD, then this is something happening at the conversion level and may have something to do with the XSLT. Hopefully an experienced MMD user can put you right.

All the best,

Grab the latest version of MMD from GitHub and see if that fixes it for you. Newer versions of xsltproc, included in various custom distributions (like MacPorts) and Snow Leopard, broke the footnote system in the copy of MMD that ships with Scrivener.

Hi Keith, thanks for putting this in the right place.

Hi Av, thanks for the suggestion. Unfortunately, it has not helped: I am still losing footnote text in the LaTeX file, after installing the MMD on Github. Any further thoughts?

Thank you,

I’d run a search on the MMD Google user group for ‘empty footnotes’. A lot of troubleshooting techniques were posted in a few threads. Perhaps you can use them to help isolate what is happening. It could be there is another xsltproc incompatibility at bay, that the fix either created or did not address.

Hi Av,

thank you for the suggestion. Unfortunately, I don’t know the software involved - for example, I didn’t know there was such a thing as an xsltproc file until you referred to . I think I may have to change my compiling method…


From what I understand, xsltproc is a command line tool that ships with OS X, so what Amber means is that upgrading to Snow Leopard has made the copy of MultiMarkDown that lives inside Scrivener not work with footnotes. I had exactly the same problem, but after installing the latest version of the MultiMarkDown folder in “~/Library/Application Support”, which supersedes the Scrivener version, it seems to have gone away.

Hi Jebni,

thanks for your comments. Unfortunately, I have done exactly what you did – upgrading multimarkdown to the latest release – and it has not helped. After that result, Amber referred to me the mmd google group, with the suggestion that I might find further help there. I didn’t. As far as I could tell, the only suggestion there involved trying to debug by reading logs of xsltproc, and that I am not competent to do.


I guess a non-technical way of approaching this is to query what exactly happened on your system? Did you run an OS update? Did you have to use Time Machine? What OS version are you currently running? If you did upgrade, do you recall what you were running before?

Hi Amber,

I was running OS X.4.11. I copied most of my home file to an external hard drive, erased the macbook’s hard drive, and installed Snow Leopard. Then I moved the copied home files back to my macbook. Then I reinstalled applications, including Scrivener and Texshop. After noticing that mmd->LaTeX files were missing footnotes, I came here, and, following your suggestion, installed the latest mmd in both my home library and the system library.

Since (until today) I didn’t receive a response to my subsequent post about not understanding xsltproc, I figured mmd->LaTeX was out. So I have reformatted most of my dissertation in Scrivener so that it will compile properly to Microsoft Word (this involved underlines & citations). At this point, I do not plan on reformatting to facilitate mmd->LaTeX compilation. So I have no personal interest in figuring out what went wrong. However, I could spend some time helping you debug, if you wanted.

Thanks for your help,

That’s all right, no need to take up your time. I think this is potentially an odd case. I’m not sure why it would make a difference, but that was a large upgrade path you took, most stopped over in 10.5 for a while. With a clean installation that shouldn’t make any difference, but who knows what all happened, and debugging a problem of this nature requires a lot of messing with the geeky side of OS X.

I’m having the exact same problem - when I compile the draft, the citations go missing and I’m left with \footnote{} in their place. If I uncheck “parse footnotes” box in the MMD settings, the citation commands remain, but there are no longer any footnotes in the document.

I downloaded the newest release of MMD and installed it in the folder mentioned above, but that didn’t solve the problem. There’s a very good chance I installed it wrong (I dragged and dropped it in from the downloads folder). If that’s not the case, though, any ideas for what else I might be able to do to solve the problem?

Just to follow up on my earlier question… I did check out the discussion in the google group and the other thread on this forum that addresses this concern. I am so sorry for being difficult, but it could have easily been in Greek/Latin/Swahili for all that I understood of it. :blush:

small words, numbered instructions, few syllabus… please!

This issue ought to be taken up in the Google group. While Fletcher, the developer of MMD, does stop by on this forum from time to time, you’ll get much faster support over there. Unless your problem is Scrivener based, but if it is that would be a new one. If your Scrivener produced MMD files look like: [^fn32]: then yes, that issue needs to be resolved here. Otherwise if it looks like [^fn32]: Yada yada you’ll have much better support over in the MMD forum.