Lost all my synopses when copying files from one machine to another

Hello, everyone, I have a situation that I hope to not have to deal with again in the future, but want to see if it’s avoidable if I ever find myself in this situation again.

Typically, when I am done writing for the day, I save my project, close it, then make a copy of the scrivener files onto a USB drive as backup. I work off of the computer save, and just save a backup at the end of every session.

I only work off of my laptop, but I was unable to use my laptop for a couple days, so I installed Scrivener on my husband’s desktop and worked there for that time. I made a copy of the scrivener files from the USB onto the desktop, and worked there.

Today, I copied the files from the desktop onto the USB (overwriting) and then plugged the USB into my laptop to copy them over there. When I tried to open the scrivener file, I got this message:

Update Project?
The project you are trying to load uses a older file format and cannot be opened. Would you like to update it? A copy of the old project will be saved in the same directory.

It was either yes or cancel, so I said yes. When my project opened, all of my synopses were gone and the writing I had done those two days on the desktop in the outline was also gone, so I lost both the newest work that had never been on my laptop, but also the oldest work, the notes I’ve been taking all month that were already on my laptop. I managed to recover everything, but only through the older copy I had on my laptop and then copy and pasting the new stuff from the desktop and emailing it to myself. Basically, this is to say, I could never get the files to act right–every time I try to open anything from the USB now, I am given the Update Project? message, so it seems like making a backup to a USB is fruitless.

The versions on the desktop and the laptop are the same, both up to date. the only difference between the programs themselves is this: I formatted the Synopsis box on my laptop to have a different font and got rid of those notecard lines, but didn’t do any formatting on the desktop version. Surely, I thought, that was just aesthetics, and the synopses copied over just fine onto the non-formatted desktop version of the program, but I guess there’s a possibility that caused a problem going the other way? The only other problem I can think of is a corrupt USB, but it still holds the other files, so I don’t know if it’s that or not.

Any suggestions you can offer to avoid this in the future would be awesome. I don’t intend to ever work on more than one machine, but it’s inevitable that I’ll get a new computer someday and move things over, and I’d hate to lose work. Thank you!