Lost all the writings I've done even from the backups

This is very frustrating. I wrote a lot for hours. And I cannot find them, even from the manual backups (I created a lot, just in case, three in my hard drive and three in my Skydrive) that did (backup to). I also checked the automatic backups, and they are not in there too. How can I find these? This is crazy. And just so you know, the files of scrivener project (template I created) I imported remains intact. The only missing are the ones I just wrote in. I did check the individual files in this folder Stuck.scriv\Files\Docs, they wont load into the Scrivener program. The only thing I see are the imported files from another Scrivener Project. Please help me as soon as possible since this is a project I need to finish as soon as possible. I do appreciate it a lot.

Could you describe a little more what specifically you’re seeing or not seeing in the project? My understanding is that you are able to find the saved project itself, but that documents are missing within that–but I’m not clear whether the files are listed in the project’s binder but the text isn’t appearing in the editor, or if the files themselves are not showing. Have you closed and opened the project since you first started working, and it doesn’t seem to be opening properly, or did the change happen while you’ve had the project open and were working in it?

Where is your project saved? You mentioned SkyDrive, and I know some people have run into problems when using this to keep their active projects; is yours saved directly into your SkyDrive folder, or are you just using that for zipped backups (which should be fine)? Have you tried using the Windows search to look for some of the missing text in your project? It could be that the wrong project is open in Scrivener, so you’re looking at a fresh, empty template project rather than the one containing all your work. You can check the “Show full project path in the title bar” option in the General section of Tools > Options to make sure that the open project is the one you expect (although obviously if there ended up being confusion about where the project is saved or such, that might not immediately clear things up).

The files (scenes) used to be listed in the binder with their texts intact last night before I saved them (back up to to my hard drive and to my Skydrive as zipped files (I am very anal, I want to make sure I have a lot of backups in two different places just in case). But when I opened my original file in the hard drive, the files with their texts (scenes) are not in there. So I tried to unzip those backups from both the hard drive and Skydrive, thinking that maybe this would have those files, but same thing, they’re not in there. I mean, they do not show up inside the Scrivener program itself. And yes, I did try to use SEARCH on the right hand side of the program, but they still did not show up. But knowing that they are probably saved within those folders (Stuck.scriv\Files\Docs) of the archive file, I looked and found them by opening them as a word file, but the problem is they just do not show up in the Scrivener program itself, which I want.

And yes, I did look at the full project path in the title bar, and I am in the right location where the file was saved.

Thanks again for the help.

Okay, I meant to use the Windows search rather than Scrivener’s search, so you could search the hard drive, but it sounds like you found the files themselves within the project folder, so that’s all I was after with that. If they’re in the directory but not appearing within the project in Scrivener, it sounds like the project’s binder file got out of sync with the rest of the project. In normal conditions, everything is updated as Scrivener works and updated again when closing the project, so this shouldn’t happen, but if there were a crash or if something else modified the files outside of Scrivener, then the project file might have gotten corrupted or just be out of date compared to the other files. Sync software can also be a culprit in causing a project’s files to get out of whack, when using Dropbox or GoogleDrive or SkyDrive or the like to keep a project shared between machines or just with a “live” backup on a server.

The easiest recovery option at this point is probably to just open the working copy of the project in Scrivener (I’d say make a backup first, but you appear to already have multiple) and then just create a bunch of new files in the binder. As you create them, they should end up linked to the existing files within the project folder, so the editor will suddenly be populated with the missing text. You’ll need to fix the title and any meta-data like label and status and to position them correctly in the binder, but this will keep your documents, synopses, and notes together per item. The other option is to create a new project and then to import the documents from the original project’s Files/Docs folder into the new project. This way you’ll only be bringing in what you need, whereas in the other way you’ll end up having to recreate any empty or trashed documents that were created in the process of making your originals–i.e. you may create a few new documents that don’t get populated with text before creating one that does, because those items never had text associated with them in the original.

To explain a little how this works, the files are all referenced numerically by the binder file–as you’ll have seen when you found the RTF files, they’re all just numbered, e.g. 8.rtf. Each time you create a new item in the binder, the count increments, so essentially what you’re doing in the one recovery method is just adding all those references back into the binder–some will reference existing documents, and some may not, if you had created an item but never given it any text or created it and then deleted it.

Thanks. And I appreciate the help a lot. What you told me worked. But the bad thing about it is that I have to re-organize everything since they are all out of order. So that would be a pain to do, but there is no way around it. But could you please give me an advice how to avoid this from happening again since I would not want to do the same process again and then painstakingly re-organize everything again. I appreciate an answer. Thanks a lot.

Well, like I said, the only things I’ve seen that cause this are if there’s a crash when the project is open or in the process of closing, when the project is kept live on a sync server, which may then not always properly update all the files within the project folder, or if something other than Scrivener modifies the project files, e.g. if you have some kind of system backup software or computer scan running that might touch the files and alter them or prevent Scrivener from saving them correctly (although in the latter case, if Scrivener is open you’d normally receive a warning message that Scrivener was unable to save a given file, assuming you’re on the latest version, 1.6.1). You also want to be careful that you yourself don’t access the project files apart from Scrivener or move the folder or any of its contents.

How are you handling your backups? Just using the “Send to \ Compressed (zipped) folder” function on the project folder should be fine, but you’d want to do that when the project is closed to avoid making the backup in the “open” state. When the project is open, there’s the File > Back Up > Back Up To… within Scrivener that can make zipped backups to any location and will take care of tidying up the files.

Unfortunately it is still doing the same thing again, even when I did the backup to (zipped folders). I would open those zipped folders and again I would be missing those files again and have to re-do the whole process again. Also I do not see any crash notice when I close the program down, so that is not the problem. As for the server synch, I don’t think that’s the problem either since I save and back up the files unto my hard drive, and not on a server somewhere. This is a lot more complicated than I thought.

In that case I would definitely make a new project–you may want to try saving it to a different location–and then just importing your work over to that. You can drag items from one project binder to another to copy them and most of their meta-data, so if you have that set in the one project you can bring it over easily to another; otherwise you can just import the numbered RTF files to the new project by dragging them from the one project’s .scriv folder to the binder of the new project.

This shouldn’t be complicated; there’s something very unusual going wrong with the way the project is saving (or not saving) the .scrivx file, and unfortunately (or fortunately) it’s not something I’ve seen happen before outside of the contexts I already mentioned, so I don’t have an immediate explanation otherwise. Did you verify you’re using version 1.6.1 (will be listed Help > About)? You also mentioned that you’re opening and checking zipped folders. Is the problem just with the unzipped folders or with the active project as well? I understand that given the problems you’re seeing, you’re regularly checking your backups, but normally of course you’d just keep working from the one copy of the project, so I just want to clarify. If it’s specific to the zipped copies, what program are you using to unzip? 7zip has problems correctly extracting the project bundle, so if that’s the program you’re using, try something else–the default Windows extractor works fine, as should WinZip and a number of others.

Hi Jennifer

I just created a new project and just saved them on my MY DOCUMENTS on the c drive and imported a new RTF file, which is also located on the same folder. Once imported, I used the DOCUMENT – SPLIT to split my RTF document into different, separate files (It is a screenplay, so I split all the scenes into separate files). After I did that, it gave me the same problems again. And the way for me to retrieve them again is to create a bunch of new texts for them to appear again, but this time, all out of order from what I did before.

Yes, this happens on the zipped files too (opened with the windows explorer) as well as the regular and the backup files.

Yes, I do have the updated version of 1.6.1.0.

As I am trying to figure this out, is it possible this is happening because of importing files (I did import a lot of files as research documents) or document (RTF) - split ? I’ve noticed that this happens only whenever I import a file (RTF) and split them into separate files (per scene).

Thanks a lot for the help again.

I am having the same problem again even after I saved the file on the C drive. And it seems to happen whenever I would change the label on the right hand side (inspector) for some of the scenes (for example, I would create Meta Date Setting such as “SUBPLOT SCENE” or whenever I would add some of the scenes to a new collection (PROJECT - ADD COLLECTION) or whenever I would make a folder and put three scenes in that folder (for example, LOVE SUBPLOT Folder). Also is there a limit to how many scenes I could create (this seems to happen when I exceed 50 scenes in a folder)? This could be a bug in the program. Please help or if it is a bug, would you be able to fix this? The reason I bought this program is to be able to do those things, and I can’t even do them.

Thanks a lot for your help.

Please answer my post since this is affecting my work. Thanks a lot.

Hi

Please answer. I just created a new file in my C drive with all the files in the same folder, and it still created the same problem of me losing my files after I do the following steps:

  1. File - Import - File
  2. Document - Split - With Selection as Title
  3. General Meta-Data - Label - Edit - Add Label - for some of the scenes I split.
  4. Add to Collection - New Collection (for example, a collection of Suplot A for some of my scenes)

Yes, I am still be able to retrieve them back, but they would be out of order and lose the meta-data settings and the collections I created for them. At the same time, I have to re-do the whole thing everytime I open the file.

To answer these questions:

  1. “if you have some kind of system backup software or computer scan running that might touch the files and alter them or prevent Scrivener from saving them correctly (although in the latter case, if Scrivener is open you’d normally receive a warning message that Scrivener was unable to save a given file, assuming you’re on the latest version, 1.6.1).”

No, I do not have a backup software. If I do a backup, for the Scrivener project, I just do “Back Up to…” and zip the files and copy and paste it onto the Google Drive. And no, I do not receive a warning message that Scrivener was unable to save a given file. And yes, I do have the latest version.

  1. " You also want to be careful that you yourself don’t access the project files apart from Scrivener or move the folder or any of its contents."

No, I do not access the project files apart from the Scrivener or move the folder or any of its contents."

Anyway this seems to me that it is a serious matter that needs to be solved in the program. Please answer if this is being FIXED. Thanks, An answer is deeply appreciated.

Anyway I did send an email to technical support, and yet I still have not got any response.

I’m very sorry for the delay in answering; I’ve been out sick and am just working on catching up. I’ve tried to reproduce the problem you’re seeing, importing an RTF and splitting into 50+ sections, moving multiple items into collections and other folders in the binder, applying labels (including a custom label), but I have not at all been able to replicate what you’re seeing. I’ve also never seen another report on this, so I’m rather at a loss here to understand why you’re experiencing such difficulties. All these things you’re doing, importing files, splitting documents, assigning meta-data and so on, are all normal uses of the software that many users do regularly and in multiple projects.

Could you try starting Windows in Safe Mode or working in a different Windows account and performing the same steps in Scrivener that are consistently giving you errors, to see if that has any effect on whether the problem occurs? Try also opening Windows Explorer so that the “project” file for the project you’re working on is visible with the Modified Date column shown, so that you can keep an eye on it as you work. Whenever the project auto-saves or you manually save, the timestamp for the project file should update.

Sorry about you being sick. And I am so glad for the response.

Okay, I will do what you just instructed me to do, and let’s see if it works.

I will get back to you with the results.

Thanks a lot again for your help and patience.

:smiley:

After following your steps and doing some experimentation myself, I think I just found the culprits.

ÎEXT. NOT FAR FROM THE SUV (GOON’S POV)Ø

Those odd characters on both sides of the sentence, I believe, are the culprits. Putting those “Selection as Title” made those files disappear. But by changing them to another title without those symbols, the files stay where they are, in order and with their meta-data intact.

Anyway those odd characters were produced by my screenwriting software Movie Magic Screenwriter when I converted my file to RTF. I did not have those on all my scene headings, but only on those texts I hightlighted with a different color of fonts on my screenwriting software.

So after finding out how to fix the problem I’ve had, I hope this will help anyone who encounter the same problems as I did.

So for now, after solving that problem, the program is now working well again. In case, it comes up again, I will let you know.

Thanks again for all the help.

Thanks for the follow-up! Would you happen to have a copy of the RTF that you’d be willing to share, either here or sending it to windows.support AT literatureandlatte DOT com? From your description it sounds like an encoding issue from Movie Magic, so that may not be something that can be cleaned up directly in Scrivener, but there should be a way to prevent the characters from causing the files to not be saved correctly in the project file by stripping them out or such. If we can get a test file for the developers to work with, that will help them see what’s going on specifically and how to work around it. It doesn’t need to be the whole script; just a sample that will demonstrate the issue is all we’d need.