Lost Images - A New Twist

On one small article I was writing, I placed some of my images under the wrong page. Not sure if that’s the right name. They’re the pages you make under the Drafts folder. When I noticed that the images were in the wrong place, I moved them using a cut and paste. Later, I noticed that the images were showing a grey box, but no images. Only the images that I moved were affected. Other images were okay.

No matter what I did, the images would disappear. I would remove the grey box and re-import the image. It would initially appear, then disappear either immediately after I would exit Scrivener and re-enter, or at some seemingly random time when I was editing the document; probably the result of an automatic save.

I went back and actually deleted the images from Scrivener and re-imported them. same behavior.

I then went out and renamed one of the offending images and imported it again. Same thing.

I don’t want to post the Scrivener project file here, but I would be happy to email it directly to you, or share it in a Dropbox of Google Drive folder if you wanted to have a look at the problem. In the meantime, I think I know what I did to cause it, so I just won’t do that again…

On another note: On one image, I added it to the bottom of the page. It went in, but it then also appeared at the top, where there was previously a grey box. I saved the project, and when I brought it back up, both images (the one at the bottom and the previously greyed out image at the top) were still there. I deleted the image at the bottom, and the one at the top went grey too. These were both the same images by the way…

I am having a very similar problem with images I paste into the document.

I insert images by taking a screenshot using Snagit, then simply pasting (CTRL-V) the image into the document.
Initially the images display correctly, however some time later some images become greyed out (see attached jpg example).

The image seems to be now lost to Scrivener because:

  1. If I right-click on an image that is displayed correctly I can select “Save as a picture” and am able to save the image to disk.
  2. However, if I right-click on one of the images that is greyed out and try to “Save as a picture” Windows reports “Image is invalid. Cannot save invalid image.”
    It is as if a placeholder has been put into the document in place of the image, and the location (?) of the image has disconnected.

Not sure if these points are relevant or not:

  • The Scriv document is in a subfolder in Research section;
  • Inclusion of the images into compile seems quite random - sometimes there, sometimes not, although once the image is greyed out it is never included in compile again.

Anyone else having this problem? Seems to be a bug. Hope you can help

Thanks,
Paul

Hello,
I have the same problem with pictures (Scriv 1.9.7.0 (Russian language), Win 10): my pictures dissapear and became grey “ghosts”. Have you solved this problem?

I don’t know if you ever solved the problem with .jpg images disappearing inside Scrivener projects, but I have something new to report:

I just completed the second article that I’ve written recently where I inserted images and none of them went bad. What I’m doing different is that I import them from outside rather than bringing them into the project first.

What I was doing earlier was importing all the images I was going to use and storing them inside the “Research” folder. I don’t remember the process from there, but somehow I would move or copy them into the document, where they at some point would go weird.

This time, with the last two articles, I imported the images from a location on the hard drive and never moved them into the Research folder. I simply inserted them into the document when I needed them No complaints. No problems.

I don’t know if that’s the key, of if it’s simply that I have gone through a couple of upgrades to Lightroom (where I export my jpg files from), but the behavior seems to have stopped.

Don

Hi

Apologies for necroing this thread but 3 years on and it seems that I am having exactly the same issue. Did anyone find a workaround, it has juts randomly started happening today.

I’ve tried manually saving, repeating the copy-paste etc and all the obvious stuff.

Thanks

I touched bases with Support a few months ago. They told me that they have not fixed the problem, but to try importing the images into Scrivener as an asset first before putting them into a writing project. As a side note, they didn’t seem to be particularly interested in whether the suggested fix worked for me.

I didn’t try it because I’ve long since uninstalled Scrivener and moved on to a different solution, but the workaround seems like it might be feasible. I was only checking because if they had somehow found a fix, I was willing to give Scrivener another try.

Given that they haven’t fixed this issue, or even tried as far as I can tell, and they haven’t been able to come out with a Version 3 for Windows that’s non-Beta, literally for years, I’ve concluded that Scrivener is a Mac only program.

Hi, I am using Windows (Version: 3.1.1.0 (1463331) 64-bit - 03 nov. 2021) and I am finding the same problem… Not showing the images in Draft folder or outside that folder. I think the problem has appeared with version 3.1 or so. I don’t use a lot of images but I recall I could see them months ago, maybe with version 3.

I opened the project files folder (in windows, inside PROJECT.scriv\Files\Data) and found some RTF files which kept the image inside (but not showing in scrivener project) and other files which instead of one image, just showed and strange symbol (see image) with “OBJ” characters.
2

@donfink Which other program where you using instead of scrivener?

Thanks!

Hi again,
Looks like uninstalling Scrivener and installing back again (the same last version) solved the problem.

Hi Javier, I’ve been having this problem since 2015 when I was using version 2. When I brought it up to the tech folks, all they could come up with was that something must be wrong with my .jpg files. Of course, I get my .jpg files directly from Photoshop and Lightroom, so I don’t know what else I could do.

Anyway, long story short, I don’t use Scrivener for anything I’m writing that may contain an illustration. Instead, I use Word or some other straight-up word processor.

Too bad too since I really like Scrivener. I could use it for everything I write if it wasn’t for this one problem.

I haven’t tried to figure out the behavior in Version 3, but if you’re reporting success, I might give it another whirl and let you know how it works.

Thanks,