Lost keyboard shortcut

In the transition to the new version, my favorite keyboard shortcut that I customized (command-k to insert a hyperlink in selected text) has been wiped out and I cannot find out how to recreate it.

Go to System Preferences -> Keyboard -> Shortcuts -> App Shortcuts. You can create app specific shortcuts there.

Thanks, I have now done that, and I have the same problem. When I hit command-K, it splits the file at that point, creating a new file.

Me too! Option+Esc for read this text to me with speech!
UG I use this everyday. Nothing will undo it. When I click it all my text disappears and puts the word Ya on the page?
Not sure what good that would be but ew!

CMD K is wired into Scrivener for Documents > Split > at Selection.

In System Preferences, you need to reassign “at Selection” (you don’t need to include the word “Split”) to another key combination. This will then free CMD K to work in line with your custom assignment.


I cannot figure this out. When I go to System Preferences, the only shortcut that exists for Scrivener is the one I just tried to create. When I go into Scrivener preferences, I cannot find mention of the split screen.

When in System Preferences, you won’t see the shortcut for Split > at Section (1) because it is wired into Scrivener by default, and (2) because the settings in System Preferences are meant for user customisations (you don’t see all of the Scrivener or Pages or Numbers shortcuts in System Preferences).

So you have to create the “at Selection” preference to overwrite the one that Scrivener defaults to. See the new image below. You should then have two relevant entries:

  1. that reassigns “at Selection” to another key combination of your choosing (so long as it doesn’t conflict)

  2. that assigns CMD K to “Add Link…”

Thank you for adding the screen shot. Now I get it, and I made the change. And … it still doesn’t work. It no longer splits the file. It (meaning command-K) does nothing when I try to use it.

Can you add a screenshot of the shortcuts in system preferences?

The Add Link one needs an ellipsis after the the word Link, and without a space after the K:

Add Link…

To type an ellipsis, use OPTION SEMI-COLON. Three full stops won’t work. Or copy and paste the line above.

The words are also case sensitive. They must match the menu items in Scrivener exactly.

Thanks so much. You figured it out. I hadn’t typed the ellipses. I really appreciate your help.

Been there. Done that. All of us, pretty much.

Glad it is working now.