Lost Project

I have read the previous posts about losing projects and know that only a few have indicated losing them. Add me to the list!

I use Scrivener to work on sermons (I am a priest) and have one project file that is 5.5 mg in size that contains all my work (research, scripture passages, sermons, etc.) for the past year and a half. While working on the project this afternoon I paused to do a quick backup from within the file menu. A dialogue box came up indicating that the backup failed. Curious, thought I. It has never failed before. No big deal. I clicked on save. Dialogue box indicated that the file could not be saved because it could not be found! And yet there it was on my desktop, open! Tried again, same thing. Went to Finder (mind you, the project is still open) and I could find the project nowhere: not in the usual “Scrivener Projects” folder in my documents folder; not on the desktop; NOWHERE!

Trying not to panic, I quit Scrivener, thinking this was just an anomaly and that I would find the file. No. NOPE. NOTHING!

Fortunately for me, I just this week purchased Leopard and have been using Time Machine for about three days. I went into TM and there was my project! 30 minutes old, but still it was there and I was able to recover the project. (I also keep a clone of my computer, but those are a week old)

It opened fine in Scrivener.

I made a manual copy of the project that I keep in a separate folder now.

Question: Why is this happening? What gives? The only thing I can think of is that maybe there is some glitch with Virus Barrier X5 which was performing a “Real-Time Scan“, something which is not supposed to interfere with normal computer processes.

It would seem to me that if there are a handful of us who have mysteriously lost files (have had them disappear) then this would be something the developer would want to look at?

Thanks for any help/assistance provided!


Sorry you seem to have lost your work. There is one rare-case scenario in which a project could be lost in the manner you mention. If you went to File > Backup To and you didn’t choose to zip up the project and you accidentally tried to back up to the same filename and path as the original project, you would lose the project - Scrivener would delete the file at the existing location (the original project if you accidentally gave the backup the same name and file path), then try to back up and find no project from which to back up. Could this have been the case? Obviously this is a nasty bug and has been fixed for the forthcoming update, and I’m glad you haven’t lost more than half an hour’s work.

All the best,

Thanks, Keith.

Actually, I backed up like I always have: File > Backup To, using the same file name as previous backups and to the same directory, and I don’t zip it up. Things have been fine doing this in Tiger as the new backup always replaced the old one. Is this a Leopard glitch? This was my first time to use Scrivener in Leopard. From now on I’ll backup as you suggest––zip/different file name.

Glad that you are working on a fix!
Glad I always back up my computer!
Glad to have Time Machine!

Thanks again…

Not that I can understand it, but this post suggests ways that files can disappear in OS X: