Lost words, auto-save not working?

Hi all,

I’m a Mac Scrivener user, but a friend of mine has been trying the Windows beta for NaNoWriMo and just had a major issue losing about 3K words. Now, I’m hoping that there’s just something that’s goofy and when I get a chance to go check out her computer tonight I’ll be able to find that the data’s not lost, but since I’m not as up on the Windows version (or Windows in general) I wanted to check here in case anyone had suggestions for what to look for. She’s running the beta 3 (updated a few days ago) on Windows Vista.

Essentially, she has the autosave set for the default 2 seconds of inactivity but it appears not to have actually saved any of her work since the last time she’d restarted the program. She’s also been taking snapshots but they come up blank. There was also a backup issue, but I’m not clear on whether that just failed partway through or what happened with that.

Clearly I’m sketchy on the details for all of this, and I apologize. I’ll update this with more explicit information after I’ve had a chance to actually see for myself what’s going on, but since she’s a bit distraught right now I wanted to hear if anyone had some advice for what I should take a look at, going in. Has anyone else encountered a problem like this?

Thanks for any advice!


Hi Mimetic,
I am in the same boat as your friend. I lost 3000 words in two files, one day’s work for Nano. I saved regularly all day, but no version of either file is anywhere on my computer. I am new to Scrivener, it looks like a great program. I am interested to know if you have learned anything new since posting.
Regards, Panthora

(Samsung Netbook NF210 with Windows 7 Starter, Intel Atom CPU N455, 1.66 GHz and 100GB Ram)

Have any of these projects been moved while they were open? That is something you should very much avoid doing, as Scrivener can’t keep track of where it moved to and so stuff can end up not getting saved right or at all.

Sorry I left this hanging. I still don’t have a clean bug report in the step-by-step fashion, and I apologize for this all being a bit messy since I didn’t get a good chance to do everything myself on her computer and be able to report it. But I do have good news in that she ended up recovering most (possibly all? word count issues) of her words. There does seem to be an auto-save bug that she’s run into, and unfortunately that’s the part I haven’t pinned down yet.

The project and files hadn’t been moved and they’re saved straight to the desktop; no sync issues. Basically the project appeared to have lost everything since the last manual save, despite seeming to auto-save during that time. When she closed and then reopened the project, the documents she’d written in since her last manual save came up blank in Scrivener (they’d been created earlier but not typed in until after the save) and the actual .rtf files all showed a filesize of 0-1KB when she opened the .scriv folder in Explorer, and opening one of the files in WordPad showed it as blank. However she then did a Windows search for a word used a lot in the recent typing and lo and behold it came up with the files.

Sadly I’m sketchy on this point, because she’s using Vista and her setup with the search shows only the document titles, so she thought they were the same files as in the .scriv docs folder but they may have been some kind of autosave from Windows somewhere else. All I’m certain on is that she did find identically named files that contained all the text when she opened them fresh from the search list, and she was able to copy and paste the text from there into the Scrivener project and save it.

Autosave still failed to function, though, when she tested it some more with new text, but I realize that’s not very descriptive. She gets the display as though it’s saving, she closes the project, and when she reopens, the text she’d just added is wiped.

Hopefully soon she or I will get a chance to really sit down and test this more with a clean project on her computer and maybe figure out helpful details.

Thank you both for the additional information. I routinely save manually, so an autosave malfunction could not the have caused my problem. I cant say whether or not I moved the scrivener file while it was open. While it seems unlikely, I guess anything is possible on my first day of using a new program. So you have given me motivation to test it out again. Nano being over and won, I am keen to use scrivener for the long hard editing job ahead.
Regards, Panthora :smiley:

I only just started using Scrivener this week and really like it - except that I’ve had this exact same problem today. I spent an hour editing my current piece, manually saved it regularly on top of the autosave (a habit from MS Word) and when I went back to reopen it…

All my changes were gone. And no matter where I look I can’t find them. I haven’t moved any files or done anything else on the laptop while editing, no other programs were actively doing anything. I had Firefox open in the background but it was not loading anything or running any media. When writing I was in fullscreen mode, when I exited this I saw the text onscreen change to reflect my changes.

I have tried searching for an alternate .scriv database they might be in but found nothing; I have tried searching for specific words but had no luck with this.

Love the program but not willing to risk losing a lot of work if this keeps happening. I have tried making another change, saving, closing and reopening and same thing happens.

ETA: Have come back the following morning to see if it was an isolated thing and altered my project slightly, saved, closed, reopened, and the changes have not been saved at all. Again, only firefox was running but doing nothing. Did not use fullscreen mode this time, just the text view mode.