Lost work - HELP!

Sorry if this has been covered before, but I’m panicking slightly!

My computer just crashed on me and closed down when I was working in Scrivener. When I started everything up again and tried to access my work in Scrivener (automatically saved in Dropbox) it says “file incompatible with this version of Scrivener”. Is there anyway I can get my work back?

Best wishes!

First thing, make a copy of your project’s entire .scriv folder, just for safety’s sake. Then, try these steps:

  1. In Windows Explorer, open your project’s .scriv folder, then open the Files folder
  2. Open the “version.txt” file there in a plain-text editor (e.g. Notepad)
  3. In the editor, select all, type “16” (no quotes), then save

Then try opening the project again in Scrivener. If it works, huzzah. If not, you can right-click on the copied .scriv folder and choose “Send to \ Compressed (zip) file” and send that zip file to support AT literatureandlatte DOT com (if it’s 20MB or under) and I can take a look at it to see what we can do–there might be another file or more that got banged up when the computer crashed.

Wow, such a quick response - and your instructions worked, I’ve got it all back. I’m so happy - thank-you, thank-you!

Lovely! Glad that was all it needed.

What’s the magic of 16? I’ve heard it again and again, but I have never been able to figure out the magic of 16.
Is it the original number of sleepless nights all in a row that Keith endured to finish Scriv?
Is it the number of nights that dinner consisted of coffee, and yet more coffee?
Is it the number of workers that Lit and Lat wishes it had?

What is the magic?

I tried to download the trial version of Scrivener to work on my NANO project when my modem crashed. That was repaired today and I downloaded again, then located my beta files and saved them to my desktop. They were found in XTML and would not save the names of the projects but I loaded the trial version anyway after uninstalling my beta version. Now I cannot open any of the saved files due since they are compatible with the correct version. I looked at the start of this post, but I cannot seem to follow the instructions about opening in windows explore. Any suggestions for getting my projects back?

Your Scrivener projects are saved as folders with a .scriv extension, inside of which will be a “project.scrivx” file and several other folders and files, including all the text documents created in your project. You’ll need that entire project folder in order to load the project–it sounds like you may have just copied your .scrivx files from inside the folders? Try using a Windows search to look for the “.scriv” extension to locate the full projects and then opening the .scrivx file from within the folder.

If you moved the .scrivx file rather than copying it, so that the .scriv folders no longer contain a .scrivx, we’ll need to do a little more work to restore the proper .scrivx file to each folder–although they’re all named “project.scrivx” they’re all project-specific–but it is doable, so once you find the folders, let me know how things are shaping up.

One of the files has a “project” that can be opened, the other files do not. It appears that I need to move the files back. Thank you.

All right, if most of the project folders are missing the project.scrivx, the easiest thing to do at this point is probably to restore the .scrivx file from the “binder.autosave” file that will be inside each project. Mainly because I’m assuming you have a slew of “project.scrivx” files all together on your desktop and it’s going to be a bit of work to identify which of them goes to which project. (If you happened to have been working on a Mac with these projects and so the .scrivx file has a real name, e.g. MyGreatNovel.scrivx, rather than just project.scrivx, you should be able to identify those and move them back to their proper folders. Assuming these are all straight Windows projects, you won’t have that option.)

You’ll need to do this individually for each project, with these steps:

  1. Open the project’s .scriv folder and then open the Files folder inside that
  2. Copy the “binder.autosave” file out of the folder to somewhere you can unzip it
  3. Change the file name from “binder.autosave” to “binder.zip”–you’ll get a warning message about changing the extension; just click OK
  4. Right-click the binder.zip file and choose “Extract All”
  5. Once that extracts, open the folder (if Windows doesn’t do so automatically) and copy the .scrivx file inside
  6. Paste the .scrivx into the project’s .scriv folder (directly inside that folder, not in any of the subfolders)

Once you’ve done that, you should be able to open the project.

Thank you! I was able to retrieve everything! The only difference in the instruction was that I was told to “Extract Here” since “Extract All” was not an option for me.

Thank you again for your prompt assistance!

Excellent! I’m glad you were able to get everything running again. So yeah, for the future, if you’re going straight through Windows Explorer to make a backup or move or copy your project, make sure you work with the entire .scriv folder as a unit. The .scrivx pulls everything together, but without all the other files there’s nothing for it to pull. :slight_smile: If you use any of the “Backup” options from within Scrivener, it will back up the whole project for you.

I’ve downloaded the NaNo trial version, and it keeps crashing on me. I’m getting the previously noted “Scrivener has stopped working suddenly.” crash note. I don’t know why it’s crashing so much, but it’s crashed once a day at least.

However, it always started right back up with all my lovely writing still there.

This last time, however, it didn’t. Somehow the sections still have the titles I gave them, but all the actual writing is gone. I can’t find it anywhere. I’m devastated. This is 14K words of a story that I’m writing for an exchange fest and it’s due on the 15th. I don’t know what to do.

I’ve tried to recover it by unzipping the autosave, but that just gives me a second version with two of the writen out scenes and without the section titles, reference materials, Scenes To Write - just two scenes.

Please help?


SongPalmese - I’m so sorry you’re having trouble! If you’ve copied or imported any work from another program, the crashing you’re experiencing is probably due to a bug with invalid characters in the RTF. This issue was fixed for 1.0, so you may want to try backing up your work and then uninstalling the NaNoWriMo trial and installing the 1.0 trial instead–it will give you 30 days of use, rather than a set expiration date, but at this point it will be plenty to get you through the rest of NaNoWriMo and beyond.

Try running a Windows search for any unique words or phrases from your missing text to see if that finds any numbered RTF files, in case they’re lurking on your drive but just not appearing in your project. You might also be able to find the text in the projet’s search.indexes file if you can’t find the RTFs. Or if you have a recent backup, you can restore from that and keep working–if it’s not a zipped backup, make sure to copy it and work from the copy so that you still have that milestone backup for the future.

MM -

Oh thank goodness. I’d searched for text strings, but had only been able to find the two scenes from one of the versions. I tried again with something else, not from one of those scenes and I did find most of the rest of it.

I can’t tell you how much of a relief it is. Phew!

I’ve downloaded the 1.0 version; I hope I won’t crash again!

Thank you!