[macOS 14] Editors and formatting settings are blank in dark mode

Just updated bot scrivener 3.3.2 an sonoma, but running in darkmode, the Main editor stays in dark, covering the document content. When I switch to light it is ok, but rather hard on my eyes (33" LG screen)

is the a different place outside settings to fix this??


Yeah, we just caught that one, and will get a fix out shortly (maybe tomorrow or the day after). You can avoid it by turning the Ruler off (⌘R). So it’s an easy one to get around in the main project window.

It’s going to be more of a problem anywhere there is text that has a ruler you can’t turn off though, like in compile settings where formatting is changed for sample text. You’ll just have to switch to light mode temporarily, if you need to use one off those areas, for now.

1 Like

Super fix :+1: it works, can live without the ruler… I just checked my macbook and there it works in Ventura and previous Scrivener.


1 Like

I’m went ahead and split this off so it could have its own heading in the thread list, as I’m sure you won’t be the last to come across it!

I just upgraded from 3.3.1 to 3.3.2 and when opening Scrivener, all my texts are gone. 11 years of standup material gone, only the titles are left.
This must be a bug and I hope there is a way to get it back? If not, why was there no warning about this before asking me to upgrade?
I am on Sonoma,

OK, it seems if I turn off dark mode and only use light mode, the text is there. In dark mode it is by some reason not visible. So I guess it is a bug, but still scared the sh** out of me. This is very unsettling indeed.

Sounds like this one: [macOS 14] Editors and formatting settings are blank in dark mode - #2

1 Like

This scared the shit out of me when I first opened up my files… light mode is killing my blind eyes, but I’ll deal. I’m just happy all of my text is still there. I hope KB can get the fix out soon.

1 Like

As stop-gap solution you can also turn off the ruler. R

I know, but I use the ruler daily.

Everything that can be done with the ruler can be done (in my opinion) more easily with the Format ▸ Paragraph ▸ Tabs and Indents... tool. It’s more accessible, you can more simply type in numbers rather than aiming at spots with the mouse.


Exactly…:+1: and you can keep your fingers at the keyboard, rather than fiddle with the mouse.
I use these format options in one of my KM macros. It saves me tons of time.
(Used in my research/fact gathering from the web)


To whom it may concern,

I updated to Sonoma ver 14.0 yesterday. I am running scrivener on a MacBook Air M1. I am running Scrivener Ver 3.2.2 for the Mac. Anyway, when I logged in this morning, all the text is gone. I have all the relevant folders in Scrivener, it opened fine, just no text. Any idea what is going on? What I can do?


A bit concerned.

Are you storing the Scrivener project on some cloud service like Dropbox? If so, check that all Scrivener stuff is available offline and make sure it is all fully downloaded. The OS upgrade might have changed such settings.

Just a thought.



I’ve been using Scriv 3.2.2 for a number of days, everything is fine! I upgraded to Mac OS14 (M1 processor) this morning, and launched the Scriv. doc I was working on previous to the upgrade. Now, everything is in the binder, but the files are blank!

I saw a suggestion to turn the ruler off (⌘R), and it worked! I can see my text again! Until I (⌘R), then it’s gone.

Exactly the same and the work around did the job. Bizzarre!

I just updated and was working in Scrivener when my machine switched to dark mode and all my text files were blank. I changed the Appearance setting to Light and the text was back. The System Default setting seems to be buggy.

I have exactly the same issue. Hadn’t realised it was the ruler being glitchy - switched it off and my text is back. Thanks for the heads up.

Turn dark mode off and you can use the ruler and see the text.