MacOS Permissions issue with .scriv file in Dropbox

I had a MacOS permissions issue with a .scriv file I had placed in Dropbox. The file would not open in Scrivener for iOS until I changed its permissions in MacOS (OS x El Capitan Version 10.11.5).

Here’s what happened:

Scrivener for iOS showed the .scriv in the Projects list. This is a file I’d created in MacOS and had been working on since June; but when I tried to open it in Scrivener for iOS, it would not open.

This is the error message I got:

Invalid project. The project cannot be opened because it does not contain a valid binder structure file.

I looked at the file’s permissions in MacOS (command + I) and saw that everyone was Read Only. I changed it to Read and Write and was able to open the file.

Greetings -
I Have the same ‘does not contain a valid binder file’ on one of my projects. It. Works fine in the MacOS version. I dont use drop box though, I copied my projects to my iPad using iTiunes. All work great except one. Here’s what I have tried -

Made sure permissions for the file were set to read & write.
Made sure my MacOS version was 2.8 - edited and resaved file.
Scanned each page and didnt see any hotlinks.
Noted the font ‘Cochin’ is used in some places, were probably cut and paste for other sources.
Checked that the project only contains photos, pdfs and text.
I shouldnt have anything encrypted.

Any help / suggestions would be appreciated.

Thanks!
Derik