Mac's not-so-sleepy sleep mode

Coming from the PC world, it was kind of breathtaking to learn that you don’t shut your Mac down in the evening, but put it to sleep simply and restart the other day right where you’ve left everything. I had to overcome strong hesitations to do so (a Windows PC you typically shut down and restart several times per day!), but meanwhile I am accustomed to it and like it this way very much.

However, a question remains, and as so many seasoned Mac-users are gathered here, maybe somebody has an answer.

Normally, when I enter my workroom in the morning, iMac’s little light breathes calmly, goes on… goes off. And everything is quiet. But it happens that I enter and the light is constantly on, one hears the computer working (even the fan was on one time, which happens rarely ever!), and it talks (“it’s nine hours”) in it’s sleep!

Why happens this? Is it normal? Malign? A sign that I did something wrong?

Any hints appreciated.

Sounds like either [1] you didn’t put your computer to sleep properly, or [2] it’s woken itself up in the night.

[1] How do you put it to sleep? With the Apple menu, I guess? Do you wait for it to sleep before leaving the room?

[2] Go to your Energy Saver control panel in System Preferences, and click on the Options tab. Are either of the “wake options” checked? They will wake your computer from sleep if certain things happen.

Sometimes the sleep mode just messes up, too. I’ve had this happen occasionally on all my laptop machines - iBook, MacBook and MacBook Pro.

Yesterday, for instance, I closed the lid of my MBPro to put it to sleep, took it downstairs, opened it up and the light was just solid on. Nothing would wake it, so I had to force a shut down and start it up again. So far as I can tell, given that it’s happened to all my machines, this is “normal” - just a minor glitch in the sleep mechanism. It’s never done any harm. In the case of my MacBook Pro, it seems to get confused sometimes when I’m plugging in and unplugging an external monitor and keyboard.

Best,
Keith

There is also the interesting problem of static electricity arousing a sleeping Mac. This used to happen regularly with my iMac in the winter on dry cold days, when you touch the cat and draw off a spark. I, or a cat, would walk past the iMac, and it would spin and whir and wake up looking for something to do. Now that I’ve upgraded to a MacBook Pro, and winter is coming on, I’ve noticed the same thing once or twice.

I’ve not suffered Keith’s sleep-that-is-not-sleep problem, though my wife’s G4 iBook did over the weekend: a steadily shining sleep light, no pulses, and it couldn’t be awakened in any way by any combination of keystrokes, button pushes, or incantations. Finally she jarred it awake by removing the battery overnight (30-second battery removals had no effect) and leaving it upside down (she was an art major, and therefore pursues her own logic in things electronic). The next morning she reinstalled the battery, charged it a bit, and then opened the lid and there she was, right where she’d left off.

Sleep in Macs and people is as yet poorly understood, it appears.

Another thing that can happen is if another device attached to the computer “wakes up” and signals the USB line, that will wake up the Mac. An optical or laser mouse that is on a surface that causes it to periodically think it is moving. Things like that.

Yeah, sleep isn’t perfect, especially on the laptops, but it is still light years ahead of what everyone else has. I love that I can just close the lid and forget about it for the night, and in the morning everything is instantly available.

Of course! Remember, I have been using Windows for more than 15 years: To expect a computer not to do what I want it to do has become my second nature… :laughing:

Yes, usually I use the Apple menu. Sometimes I hit Alt-Apple-Eject, when I have to jump off from the keyboard.

There is only one wake-up option, and yes, it’s switched on. (I’m still on Tiger.) I don’t know how it’s named in English, in German it’s “bei administrativen Ethernet Netzwerk-Zugriffen aufwachen”.

Is it possible that my Mac is looking for Emails while it is supposed to sleep? Ethernet, that’s the cable to my ADSL-router.

“Is it advisable to turn this option off?”, asked the former Windows-user anxiously… :laughing:

Do you have any auto-backups or auto-syncing set up? That might be waking it up. Also, I’ve dropped books on the floor and my Mac mini will wake up just from the vibrations.

I don’t know German, but I’m guessing this is the “Wake for Ethernet network administrator access” option. This wakes up your computer if a network administrator tries to access your computer remotely. I doubt you need to keep it checked, unless you have a network administrator who needs to access your computer.

As Khadrelt says, I think you can probably safely turn that option off :wink: Amber’s point about USB devices is a good one, and the same can happen with bluetooth mice and keyboards, too.

I have switched it off now. This morning everything was as it should be. We’ll see…

What else do I have? No auto-syncing or auto-backup whatever (I do my backups manually). USB: Keyboard (and the mouse at the keyboard), printer. Ethernet: DSL-router. That’s it. Bluetooth is switched off, Airport is off.

OK, thanks for your comments. I ring the alarm bell should my iMac’s sleep be disturbed again, otherwise I assume that the DSL router was asking “are you still there, computer?” and that was waking it up.

Just a note that on the newer Mac laptops with a “safe sleep” mode (which writes all memory to disk - handy if you want to change the battery in a laptop while it’s asleep), it takes the computer a long time (up to 30 seconds) from when you select “sleep” to when the computer actually goes to sleep, even though the screen goes black straight away.

I’ve found that if I select “sleep” then shut the lid of my laptop without waiting for the computer to go completely asleep (hearing the hd spin down and the sleep light to go on), it often gets confused and goes into Keith’s false sleep mode, running out the battery sometimes, and just generally needing to be rebooted to work.

That doesn’t help the original poster with an imac, but it might help the laptop owners. Apparently you can disable safe sleep mode on the command line, but it’s pretty nifty when you’re on a long trip with a spare battery and not needing to shut down to switch it and keep working

My 24" iMac never goes to sleep by itself. I always have to manually put it to sleep. I’ve tried everything, and no solutions work for me. But at least when I put it asleep, it stays asleep till I wake it up.

This is one of the Mac topics on which I’ve given up.

Oh hey, there’s a “sleep” option in the apple menu…

I just shut the lid. About 2 seconds later the little white “breathing” light comes on to tell me it’s asleep. It never occurred to me to actually pick a menu item to put the laptop to sleep!

The SLEEP option in the Apple menu is necessary for those of us who also work on desktop machines, where “closing the lid” is impossible :wink:

Your Mac, as a UNIX system, also performs required daily maintenance activities automatically during the wee hours of the morning, when the machines are normally unused (1:00 or 3:00, IIRC).

Always sleeping your Mac overnight, IMO, will not allow these functions to be executed. Of course, you can schedule these maintenance routines to run when the machine is not sleeping, via the terminal or a GUI utility.

YMMV

But are you saying the desktops do not go to sleep automatically? I spent atrocious amounts of time trying to tune my iMac to do just that…

Incorrect, and we went over this some time ago in these very forums. As of 10.4 (i.e. Tiger, not Leopard, so this has been a feature for almost three years) OSX runs a daemon that monitors for the cronjobs; if the computer is asleep when they should run, they are instead automatically run when the computer is woken.

No, I’m saying that if you want them to go to sleep right away, you have to choose the Sleep command. Of course desktops will sleep automatically after a certain period of time if you have them set to do so, but often that’s not fast enough.

Also, with the towers at least (would be surprising if iMacs are not likewise), you can use the power button to engage sleep mode. Just press it once and it should go into sleep. Don’t hold it down as that will force the system to power off completely, not going through the proper shut-down scripts.

In Leopard, you go under Energy Saver in System Preferences and make your choices there for sleep. (On my Mini, there are separate time sliders for the computer and the monitor.) Using the Power button to engage Sleep is optional in Leopard and you need to check the box under Options if you want to use it.

You can also set Hot Corners, which is the lazy… uh, my way of doing it (usually). :slight_smile: