Maintaining columns within Outliner

I am trialing Scrivener and have gone through all the tutorials - loving the software so far. I am so keen to dump MS Word which is my nemesis.

I am having trouble maintain the columns that I select within Outliner. I am going to VIEW-OUTLINER COLUMNS and then manually selecting items 1 by 1 (would be good to be able to multiple select from the drop down menu - but only a small point). I successfully set it up at Manuscript level but then when I close down and return all my selections are gone. I have tried document by document and the same thing happens. Do I have to save this as default or something?

I’m sorry if this is covered somewhere but I checked out your FAQ’s and other query streams and couldn’t find the answer.

Thanks and again - great software

We’d have to break menu convention to keep the sub-menu persistent. Menus are support to dismiss once you use them. But there is a quicker way to add and remove columns: to the right of the column headers in the outliner, you’ll find a down-arrow button. That’s easier to use than the View sub-menu.

But ultimately I think you’ll find that this is not a long-term problem. Right now the software is new and your playing with the features and using them more than you will in a regular fashion. Generally speaking, you evolve what columns you use gradually over time, and after a while it might be years between uses of this menu!

Anyway, the main problem is the UI settings not sticking, it sounds like. I can’t reproduce this myself. Here is what I tried:

  1. Created a new blank test project called ‘columns’
  2. Clicked “Draft” in the binder
  3. Pressed Ctrl-3 to switch to Outliner mode
  4. Clicked the down-arrow button in the columns header to add “Modification Date”
  5. Pressed Alt-F4 to close the project
  6. Relaunched Scrivener
  7. Used the Recent Projects button to reload ‘columns’

At this point I had the column settings I left it with: the four default columns and Modification date. If you follow this sequence precisely, do you observe different behaviour?

I just followed the line of logic you used and couldn’t replicate the problem either - although it was consistent for 2 days previously.

Hopefully it’s just new user error and solved now.

Thanks for your help

It could have been splits, have you been playing with that feature yet? Each split editor can store its own column settings. That’s very useful as you can have two different basic layouts—but if you aren’t aware of which split was last closed, it can be a little confusing and make it appear as though your settings have reverted, when in fact you changed Split A, and are now looking at Split B unaware.