Major display bug for scripts on Microsoft Surface Pro

I just bought a Microsoft Surface Pro 2 and installed my favorite writing program, Scrivener. The app seems to work great in normal text modes for novel writing etc. Unfortunately in scriptwriting mode it is almost illegible. The line spacing literally overlaps slightly, and the margins themselves seem way off.

The Surface has a full 1080 display but it comes with the desktop scaled to 150%. This is because the display is only 10.6 inches and the interface is very hard to see and interact with at the normal 100%. But I changed it back to 100% to see if it would solve the problem and it did. The interface is very small but the text looks perfect.

So I’m assuming that the bug must be caused by the desktop scaling. And this is more than a display issue as it also affects the compile. The compile looks right at 100% but wrong at 150%

Has anyone else ever ran into this? I don’t have another computer with me at the moment but I would like to know if this bug is repeatable on a computer other than a Surface.

I’ve included some screen caps of the problem.


The 100% pic has a 100% desktop scaling and 150% Scrivener scaling. I can scale it in scrivener to anything and it still looks right…the line spacing is correct and only the margins change like normal.


The 150% pic is at 150% desktop scaling and around 135% Scrivener scaling. But it doesn’t matter what scaling I have in Scrivener, they are all wrong…line spacing is mashed together and the margins don’t change like normal, they are locked to whatever weird setting the bug is causing.

Now normally I would just change the desktop scaling when I wanted to write scripts in Scrivener but windows makes you log out for that change which means you have to close all your apps and log back in…a pain. Also the interface is just too small to work with as a touch screen or even just being able to see everything.

I hope you guys can figure out this bug as I absolutely LOVE Scrivener! I use it for almost all my writing and I really, really want to be able to use it on my Surface.

Please let me know if I can help out in any way.

Thanks,

Michael

Just my 2p / 2c. I think it’s windows. I ran into what I believe is a similar problem (but with a different program) when I changed to my Win7 PC. I got a larger screen and windows asked me if I wanted to expand the content to fill more of the screen. Being short sighted (literally as well as maybe metaphorically) I said “Yes”. Great, no problem, UNTIL I found that one of my favourite programs i couldn’t see buttons in the pop up windows. As THAT program had just been updated, I assumed it was THAT program. It wasn’t until I changed the screen zoom back to 100% / default, that I was able to see the buttons that everyone else was talking about. In pop up windows, those buttons were missing or partially missing because windows seems to make the zoom by cutting off anything near the margins. I am assuming that this could be a similar effect.

Thanks for the reply. I guess what I am wondering, is that if it’s just a windows problem, then why does everything look fine when not in scriptwriting mode? I have a novel I’m working on and it looks just fine. It may have something to do with the weird line spacing and margin requirements when working on a script. I’m going to play with a few settings, maybe modify some of the default margins and spacing, and see if that makes things better. Even if it works it won’t fix the problem (scripts are very exact in all of their settings for a reason) but I know everything is wrong now and if it fixes it visually, then at least it will be more comfortable to work with when I’m writing.

After playing around with it for a bit, I may be able to come up with some custom script settings that will work with the desktop scaled at 150%. Unfortunately I am having trouble saving my script settings. Sometimes they save and sometimes they don’t…and lately they haven’t at all. I’m actually getting the margins and font to save but not the line spacing.

Is there anyone else having any problems with this?

Have you tried any of the solutions here? It may be possible to disable the scaling for Scrivener specifically without affecting your other programs, although that may still not completely solve your problem if it doesn’t allow you to interact easily with Scrivener’s interface. Upgrading to 8.1 is also listed as a potential solution, if you’re still on 8. You could also try adjusting the compatibility settings, although Scrivener should work fine in 8.1, so I think this is more specifically a Surface Pro issue than a Windows version incompatibility.

Thank you for your help. I looked up a few of the possible solutions that you offered and found a few things on them. Unfortunately I tried them out and they simply do not work. I’m running 8.1 already and tried to disable scaling on Scrivener but it only keeps it large and won’t allow it to go small which means it still has the problem.

I played around with creating a custom scripts setting for my surface but ultimately decided against it. While it is possible and I came up with something that is very close to true script look, it looks really bad if I use it on my desktop computer. I keep everything in my dropbox account and switch devices often so I need it to work on everything. It also doesn’t export right.

Until the bug is fixed I will simply have to change the scaling and log out and back in every time I want to write. The interface is way too small but it is possible to use it.

One silver lining is that once I’m in writing mode I don’t want to leave it to browse the internet or other distractions because I would need to change the settings and log out. So in the long run it might be a good thing :slight_smile:

Bah, oh well. Since you mentioned that the text looks fine when you’re not working in script mode, could you let me know what your text settings are there vs. what script settings you’re using where lines overlap? Font, font size, line and paragraph spacing. I’m guessing the issue here is with the exact spacing used in most of the script settings, but if you could confirm from your own testing, that would be helpful!

IT IS DEFINITELY A BUG!

I decided to try one more thing. I started a new project as a Novel instead of a script. I wrote a few paragraphs in Novel format and everything looked perfect. Again, just to be clear, Scrivener scales perfectly in normal writing mode. Then I switched over to script mode just to see if it would screw up on a document that started in a different mode and looked perfect…

It REALLY screwed up. When I hit enter twice to bring up the script element selection it started flashing the element selection menu endlessly and I couldn’t make a selection. It wouldn’t respond to typing or anything. I switched to full screen mode but the selection menu continued to flash repeatedly. I switched back and decided to try making a new document to make it stop. It made a new document then “Scrivener” made another document on it’s own, and another 10, 20, 50 documents…I thought it would go endlessly but it finally stopped. I deleted all the new documents and went back to the original to try script mode again. I could make a script element selection but I couldn’t type anything.

I finally decided to close Scrivener and open it up again. When it opened back up I could type again but the script format was all screwed up again like I wrote about in the original post.

This has to be a BUG. Scrivener works perfect in normal modes but as soon as you turn on script mode it goes all wacky.

This may not be a big issue now (I’m the only one who has posted something like this) but it may become a bigger deal in the future. As PC’s get higher resolution displays and become smaller then it will become increasingly common for them to use the windows scaling feature. It’s a very useful feature, it allows you to interact with interfaces that should be way too small in normal modes. It is the default for all Surface Pro’s and may become the default for a lot of devices in the future.

For now I will go back to switching modes and writing my scripts in an almost impossibly small interface, but hopefully you guys will figure this one out soon.

Michael