"Make Formatting Default" does not equal "Use Formatting in Current Editor"

Tonight I was touching up my default styles in RC10 and ran across an odd behavior regarding default styles.

When setting paragraph spacing for your Scrivener-wide default styles, there is no way to set it in Options, Editing, Formatting. You can set line spacing, but not before/after paragraph spacing. If you have it set on the current paragraph in your editor, clicking “Use Formatting in Current Editor” will ignore paragraph spacing.

Similar results in Project, Project Settings, Formatting. If you define different formatting for the current project, there is no to set paragraph spacing OR line spacing here, and clicking “Use Current” will ignore the currently set paragraph spacing.

The only way to grab paragraph spacing into your defaults is to use Format, Make Formatting Default.

Have a look at “Other” at the bottom of the dropdown! Works for me, at least paragraph spacing is there to change.

:smiley:

Mark

Good eye, that. So yes, that solves the issue with manually setting options for the Scrivener-wide default style. However, there are still two issues:

  1. I am still not seeing any way to set this in the project-specific default formatting
  2. The buttons that are supposed to allow you to take the selected formatting and use it as your new default still do not seem to pick up those settings

Devin,

I’ve just tested it, and can confirm: the button to use the current formatting doesn’t work (in Project Settings — it does work in Options > Editing > Formatting, though, AFAICT).

Definitely a bug.

You can set the line spacing in Project Settings > Formatting, though: it’s the drop down box on the right of the tool bar: click on that and choose ‘Other’ at the bottom of the list.

[attachment=1]Screenshot 2020-09-29 at 08.50.06.png[/attachment]

[Edit]: Just a thought: at times over the betas, the sizing of the settings dialogues has been a bit off — is it possible that you’re not seeing the full width of the dialogue? I can drag the right edge to make the line height control disappear and vice versa. There is a small ‘continuation marker’, but when you click on it, it doesn’t mention the missing line spacing control. That sounds like a bug, too.

Could that be the problem?

[attachment=0]Screenshot 2020-09-29 at 09.01.44.png[/attachment]

As I don’t think the latter has been reported yet, I’ve submitted a bug report — I hope you don’t mind.

That was it:

[attachment=0]project-settings-formatting.jpg[/attachment]

Thanks for the extra set of eyes!