Managed to Crash the Program?

** The notes the follow the numbered steps below may indicate the source of the problem I’m reporting, but I included everything as I wrote it to give the most information possible.

**
I had a project that I’ve been working on open this morning and was working between documents. All seemed okay. I decided I wanted to rename a file and then move it up into another group. After I made the move, I got the spinning beach ball and had to force quit. As nearly as I can recall, here are the exact things I did:

  1. Had split windows open with two different files.
  2. Decided to split one of the documents into two. Did that and all seemed okay.
  3. Clicked on a different file (not open in either window.)
  4. Double-clicked on the file to rename it and gave it a new name.
  5. Immediately moved the file into a group just above the one it was in, so it was ultimately moved one level lower.
  6. The file showed as moved to the new location, with my cursor still on it, but now I had the spinning beach ball.
  7. Forced quit after about 30 seconds.
  8. Restarted Scrivener. The project I had been working on came back up, with the cursor on the file I’d moved, but it was grayed out.
  9. I tried clicking on the file with the cursor and got the spinning beach ball again.
  10. Forced quit again, then rebooted the computer.
  11. Reopened Scrivener and the project was there, but it did take a brief time for it to show up.
  12. Clicked on another file in the project and the cursor moved there.
  13. Added a new file in the overall area I’d been working on (it was in the Reseach folder, which I’d renamed Reference a long time ago).
  14. I did hit enter on the newly created file, then I deleted it. Back to the spinning beach ball.

I tried opening the Tutorial file and all seemed okay. I reopened the project in question and it seemed okay. I tried creating another text file under drafts and that was fine. I created a new folder in the reference group and that’s okay. I deleted both files I’d created and everything still seems okay.

I have followed the steps above (creating a new file and then moving it up into the group above) and everything works okay, so the problem appears to have been transitory.

Except for having renamed and then moving the file immediately, the only other thing I’d done was reassign the keyboard shortcut for splitting a file just before all this started, and then used the shortcut to split the document I’d been working on. I did stop and restart Scrivener to make the shortcut take effect.

Interestingly, the shortcut I’d created no longer shows under the System Preferences under keyboard/mouse. When it went back to Scrivener, the shortcut still shows on the menu, but when I try the key combination, I just hear a beep and nothing happens. I could make the split using the edit menu. I did that and moved the split file and everything still seems okay.

I think the shortuct may have caused the difficulty. I have tried quitting Scrivener twice and after restarting the program, still see the shortcut keystrokes on the menu. I just tried using the shortcut keys and amazingly they work fine. Go figure. If it seems relevant, I can’t tell you more about the shortucts, but maybe this is just an overall system glitch?

I didn’t want to lose this posting, so I’ll send it, then try shutting down and restarting and see what happens.

** Just to follow up: I shut the computer down and restarted. I still don’t see the shortcut on system preferences list, but it’s still on the Scrivener menu and it still works to split the document when I use it. I have checked and don’t see this shortcut used anywhere else in the system or Scrivener, but its control-option-command-K.

I’m not a long-time Apple computer user and don’t know all the in’s and out’s, so consider that among other factors.

Margaret

Curious. Could you please just confirm that you are definitely using beta 2 and not beta 1 (if you are not sure, go to Scrivener > About Scrivener and check what it says at the bottom of the window).

Also, how did you move the document? Did you drag it with the mouse, or did you use the “Move up” keyboard commands (this makes a difference)?

Thanks,
Keith

I’m using version 1.0 RC b.2 and I used the mouse to drag the file up.

Margaret

A follow-up note: I went back to my project and moved the file that caused the problem back to it’s original place. I either renamed it before or after the move (sorry, I can’t remember which now). Then I tried moving the file back up to the group where it had been and managed to get the spinning ball again.

I was able to rename another file and move it into the same group without problem, so perhaps this one file has some corruption issue? I hadn’t worked on/with it in days, but the idea does occur to me.

The odd thing is that I tried this move/rename series of events again after I wrote the above, and this time everything worked fine. Something’s going on, but it’s hard to say what.

Margaret

Is there any possibility you could send me the project (support@literatureandlatte.com), along with exactly what I need to do (which file etc) to repeat the issue? I can only fix it if I can recreate it, which I can’t at the moment. I perfectly understand if you don’t want me to see your words. One way around that is to copy the project and do a Replace All on random letters so that I cannot read your text (ie. so that it is gibberish). Then make sure you can repeat the bug with the gibberish project and send it to me with instructions.

Many thanks!
Keith

I’ll send you the project.

Thanks,
Margaret

Problem found: if a synopsis contains only whitespace, this will hang the app when you hover the mouse over a document in the binder to see its tooltip. For some reason, Apple’s implementation of tooltips is a little shoddy here (perhaps because they only introduced automatic tooltips for tables in Tiger) and hang an app if they have no text in them. I already filed a bug about this with Apple sometime ago. Actually, I thought I’d already checked for this, but obviously not well enough.

So, I’ll fix this for beta 3, but in the meantime, make sure your synopses either have some text in them or are completely empty (no whitespace on its own).

Although this bug seemed to have nothing to do with tooltips, this was the root cause.

All the best,
Keith

Thanks for all your help, Keith. I really appreciate it. And now that you found the problem, I do remember deleting the synopsis from one or two files where’d I’d just played around and put in something meaningless so I could see how it showed up in outline view.

I also managed to get the system preferences/shortcut issue resolved by redefining the menu item to another set of keystrokes, then deleting them, then going back to the original ones.

Yesterday obviously wasn’t my day to work on computers!

Margaret