Margin/indent settings

A message back in 2011 included: When I import a Word doc, the text only fills half of the main Scrivener screen. How do I set a default that allows me to use the whole screen for my text view?

I have noticed this as well. Text pasted from Word comes into Scrivener with a substantial right margin (468 points). I select the text in question and change its right margin to zero. As it happens, the current line-height setting is 1.5 lines. I change it to “single.” I click OK. A query appears: Do you want to apply also paragraph indentation?

If I click NO, the change to single line spacing is applied but the right-margin change is NOT applied. If I re-open the spacing dialog, the 468-point right-margin setting is still in effect. If I change it to zero a second time, then click OK and this time click YES in response to the query, the right-margin change to zero DOES take effect.

Why is that?

This is also odd: I select all the text, open the spacing dialog, and enter a right-margin setting of 1.0 pt. All other indentation or margin settings are 0 pt. Please see the attached screen capture for the result.

Surely it must be a bug. If not, why does it work this way? Scrivener appears to be interpreting the right-margin setting as if it were an instruction concerning the line length.

(I chose 1 pt in this case not because I wanted a 1-point right margin, but just to see what would happen.)

You’re changing the right-indent, not the right margin. Margins are set in the Page Settings of compile or in File > Page Setup… for printing straight from the editor; they have no effect on the display in the editor. Indents set the distance of the left and right edges of the paragraph from the left margin when compiled/printed. In the editor you will see the text indenting from the sides of the ruler–whatever the width of the ruler is–because the text simply wraps to the size of the editor, but consider the edges of the ruler as the inside edges of your final margin. If you have set the margin to 1in on the left, then a first line indent of .5in will ultimately put that at 1.5in from the left edge of the page when compiled. Likewise, if you set a right indent of 1in, and you compile with a 1in left margin, that would cause the text to wrap 1in from the left edge of the page, giving you a 1in column of text.

Set the right indent to “0” to have no right-indent; the text will wrap at the right margin, and at the edge of the editor in Scrivener.