Margins/scale out of whack after Compile

Hi, all -

I’m delighted with the 2.0 version of Scrivener - I especially like being able to have a page view.

My question is about margins or the scale of the text within a page once I’ve compiled and exported the draft. I compiled and exported in RTF, and then in MSWord I’ve been fiddling with formatting (double-spacing, TNR font, etc). But when I come to print, the document is scaled oddly so that the right and bottom margins are way too big - at least two inches each, even though I checked the margin setting in Word and it appears to be 1" all around. Basically, the text is set too high in the northwest corner of the page, and I’m not sure what I did to get it there, or how to fix it!

Sorry if this has been discussed elsewhere - I did search Tech Support but didn’t see an answer.

Thanks for any help!

best,
Emily

Just to add to the info: What happens is that when I first open the document (RTF) in Word, after it’s been compiled, it initially looks as though the margins are fine and equal. But then as the word count goes up, it jumps to another layout, the one I described before - with the right and bottom margins about double what they should be.

Advice welcome!!

Thanks -

Emily

Hello! Still having a problem with the exporting of my document into a correct fit for the page . . . Can anyone help?

Thank you!

Emily

Hi Emily,

Sorry you’ve been left hanging. It’s a little difficult to understand what is happening, though, as the problem seems to be happening - if I understand your description correctly - in Word. Is that correct? Are you saying that when you first open the RTF in Word, it all looks fine, but after a while of working in Word, the margins in Word get messed up? If so, all Scrivener does on export to RTF is store the margin sizes for Word to read - beyond ensuring that Word reads and shows the file properly, it doesn’t have any control over what Word does in the future. Could you perhaps post steps on how to reproduce the issue, with sample project? Or perhaps post some screenshots that show the issue - how things start off and how they end up?

Many thanks,
Keith

Hi, Keith. Thanks for writing. I understand that if it’s a Word issue, there’s not going to be a fix here . . . but I’ll try to explain a little more about what happens and see if there’s any info you might have.

  1. I go to compile my WIP in Scriv 2.0.4 and choose file > compile > original setting w/ “use project page set up” button checked. (Is that right?) I choose .RTF/word compatible and press compile. I save the document into a folder in Word.

  2. I open the RTF doc through Word and at first it looks fine - is centered properly on the page. But within a few seconds it “jumps” to an altered layout (without me doing anything), with the right and bottom margins too big. I also notice that there’s no scroll bar on the right side of the doc window, not sure if that’s related. Word says that the margins are the same 1" all around that I usually use.

I don’t know how to post a screen-shot - does this give you more info? Thanks for any advice. I’ve never had this happen on previous compile/export moves (although this is my first time compiling/exporting using the 2.0 version). Nor have I ever seen this happen in a Word document before.

Emily

Hi Emily,

Have you checked your margin settings in File>Page Setup… (also accessible in the compile pane if you click that button in the Text Options settings you were talking about). It’s possible you have a bigger margin for the right and bottom set there, which is coming over into Word, although it’s odd that Word isn’t recognizing it as part of the actual margin if that’s the case. Worth checking, at any rate.

Hi, and thanks for the suggestion. I checked the page margins in file > page setup, and they were all correctly set for 2.54 cms. Just to try, I changed them all to 1 inch, and went through compile/export again - same situation occurs, with the text jumping to the left after the document opens. And even when I save it as a word doc, no change. Also, there’s still no scroll bar, which I find weird.

Emily

Some more info: now I’m thinking this issue might be because this is an older project from the 1.5 version of Scrivener, which I saved/uploaded (or whatever the term is) into 2.0 when I upgraded.

I created a new test project, and when I compiled/exported, the page margins are okay. However, it still looks kind of weird in MSword - there’s greying out on the background which I haven’t seen before, and now the vertical scrolling bar is missing.

I tried to take a screenshot but I’m not sure how to attach it here.

thanks!

Emily

Hi Emily,

To attach a screenshot click on “Upload attachment” underneath the area where you write your reply.

Thanks!
All the best,
Keith

Okay, I’m going to attach a screenshot of the new project - Scrivener text! - which shows that margins are okay but other stuff looks weird, like no scroll bar?

e.

Are other documents opening in Word okay, from other programs?
Thanks,
Keith

Hi, Keith. Yes, other documents open normally. I did figure out how to reinstate the vertical scroll bar, but the right margin issue remains on my WIP that was upgraded with the 2.0 switch. Can I PM you a screenshot of that? I’d rather not post to the forum, but I’d love for you to see what it looks like.

Thanks!

Emily

Hi Emily,

Even better, you can send it to kb-tech-support@literatureandlatte.com - if you want you can zip up and send me the project to that address with instructions on how to reproduce the problem, too, so that I can see it in my own copy of Word.

Thanks,
Keith

Thank you, Keith!! I’m emailing you now. Really appreciate your patience and help with this -

Emily

Well, my husband, who has never used Scrivener in his life (yet!) took one look at my Word document by scrolling down through it and said, “you’ve inserted a comment here.” I said, yes, I know. He said, “maybe the comment is screwing up the margin.”

Presto, voila, I removed the comment - and the right margin flipped back to normal.

SO RELIEVED!!!

Sorry, everyone, for all the headaches. I’m sure there’s a way to include comments that would keep your margins where you wanted them, but I’m fine without using it and just am happy to have my page layout back again. Thanks for your patience!

best,
Emily

Ahah. At least it has a happy ending. :slight_smile:

I haven’t got a recent version of Word (actually, with my other computer at the shop, I haven’t got any version at the moment) so I can’t tell you exactly how to do this, but if you print without including comments, it shouldn’t affect the margins (which are, as Word informed you, 1" all around). It’s mostly a display thing, and you may be able to adjust how wide the margin area is if you do print them, although I’m less certain on that.

Learn to live with it! This is how Word displays documents with comments – one of many dubious design decisions taken by the Word programmers. The extended margins are just to make room for the comments to be displayed. Once all the comments are accepted or rejected the displayed margin will jump back to where the margin really is.

The reason for the jump when you open the file is that when you open a document in Word it displays the first page quickly, but perhaps inaccurately, then works out the layout of the rest of the document behind the scenes. As you say, during this period the word count goes up and Word works out how many pages there are in the document. You’ll also see the handle in the vertical scroll bar shrink as Word works out what fraction of the total you are looking at. Apparently Word also takes a while to find out that there are comments in the file. When it does, it turns on the wide margin to display them.