Marked2 >> Scrivener

Anyone care to reply with an idiot’s guide to using the Marked 2 to preview Scrivener projects?

I’m clearly missing something - and am having inconsistent results. Sometimes it previews the section that I’m working in, other times it previews the entire project. :unamused:

And I’m not even sure which of the two is the expected behaviour! :blush:

What are you supposed to do to initiate the preview? Drag and drop the entire Project onto/into Marked 2, only the document after you’ve opened the Scrivener project, or must you open it from inside Marked 2?

Would really appreciate some tips - as I’m pretty sure this is supposed to be straightforward!

I don’t know Marked 2, but if you want to use any Markdown previewer which renders the Markdown as HTML, you need a Markdown (usually .md) file. Maybe you’re sometimes getting something that looks like a preview by dragging an RTF file from the binder, but this isn’t Markdown.
You can export a Scrivener project to Markdown by using the Compile dialog and the MultiMarkdown option.

Marked 2 does support “opening” a Scrivener project. It’s a passive scan, so you can have it reading the component files of the project while you work on them. It will preview any files that are located within the Draft folder that have been marked to include in compile. So that probably explains why you get varying results.

As for how to do it, I just Cmd-O from within Marked and load the .scriv.

Marked 2 has never actually worked for me with a Scrivener project of any complexity.

Thank you, that ^^ was what I was missing!

And thanks to all the others who replied, will have a look at your suggestions!

Oh, and FWIW, here’s a brief explanation for why I’m trying to use Marked 2 for quick previews:

I make extensive use footnotes, given what I am writing. I have played around with both the inline and inspector footnotes options, but keep reverting to the former, since it really helps checking how the complete narrative is being set out [i.e. main text along with ‘secondary’ text in the footnotes].

However, it frequently happens that I want to focus on the main text only (to check the flow/detail provision etc.) - and this would then usually involve compiling to Word, and “reading” it there, with the footnotes ‘out the way’ from the main.

I realise Marked 2 offers a convenient way to do this, since it essentially does the same thing as Word, with hyperlinks to the footnotes, and the latter down below as endnotes, but with a useful to/back option thrown in. Since Marked 2 is a “live preview”, I can leave it open, and quickly jump across if I want to see how what has just been written/changed ‘reflects’ from the main text point of view. Not needing to compile into Word each time to do this, is a huge plus.

As mentioned above, I was getting inconsistent views in Marked 2, because I had completely missed the part of it only previewing/updating what was selected to Compile in Scrivener [thanks AmberV!]. This is going to make it even more flexible for my use-case!

You do realise you can convert inline footnotes to inspector footnotes when you want them out of the way of the main text, and then back again to inline footnotes when you want them there?

Mark

Yes I do, thanks. But as mentioned, given I would prefer to simply leap across and quickly read - with them ‘out the way’, and then jump back in, the Marked 2 option is quicker.

But mainly, my OCD kicks in big time when the conversion is made, and when they are brought back from inspector to inline footnotes, Scrivener automatically inserts a leading space at the start of each inline footnote again. I know it can be simply ignored, but is annoys me no-end [1st World problems], and I’ve found it makes it a bit trickier to spot additional spaces in the main text, either immediately before or after the footnote text. Again, pretty sure most aren’t bothered by it, but it gets me every time. :blush:

As for those leading spaces, unless they bother you aesthetically, you don’t have to worry about them. The compile will strip out prefix and suffix whitespace from footnotes—the idea being that given how the text engine draws those bubbles, it looks a little nicer with some space around them, so you shouldn’t be penalised for doing so.

I use Marked2 to get a quick ongoing look at my work without needing to compile. I find this helpful (and I believe it’s the reason that Marked2 exists), but it would be nicer if it actually looked right, with proper spacing. In Marked2 > Preview > Toggle Source View, you can see that the problem is HTML
tags between paragraphs, rather than paragraphs enclosed with

.

Any idea why this is and what I can do to fix it?

It’s hard to say without more data as there may be multiple ways to achieve that end. I know how to insert a line break on purpose using MultiMarkdown: put two spaces at the end of a line.

I know this is a very old thread, but I’m resurrecting it as I was going to ask how to get the text from Scrivener to update in Marked2 without having to interrupt myself to compile each time. As soon as I had entered a suitable title, the forum software listed a few threads similar to what I was going to ask, with this thread at the top. It exactly answers my question and may potentially help others who were wondering.

Also, I really appreciate this feature of the new forum.

:slight_smile:

Mark

1 Like