May be a bug?

I don’t know if this is a bug (Not too good at using search features on forums so I had a flick through and couldn’t find what I was looking for (Maybe I missed it?)

When I save my work and close scrivener, I open it back up and random scenes will just vanish. The page will still be there, but there will be no text on it whatsoever. (It’s just aswell that I back everything up x_x)

Is this a bug or is it a problem with my PC? I’m running Windows 7, if that helps.

Otherwise, aside that bug, this program is such a godsend.

Are you using “Save as” to save your work, and then clicking on the .scrivx file to open it?

If so, then you need to realize that Scrivener automatically saves your work after every brief pause, and when you close scrivener if necessary. “Save as” creates a new copy of your entire project folder (there may still be a bug that allows you to next new project folders inside of other project folders), and it then sets the current project to be the new copy. So if you use Save As, do some work, and then close your project, only later to re-open it via the Windows file browser, then that’s why you’re losing work.

Note that the File-Save option usually doesn’t do anything (Scrivener has probably automatically saved your work before you were able to navigate to that menu).

In short:

  1. You don’t have to do anything to save your work. Scrivener does that for you.
  2. If you want to back up your work, use File-> Backup to.
  3. If the above scenario is not what you are doing, then this is likely a bug. If possible, pay close attention to your workflow so you can provide step-by-step instructions on how to re-create the bug.

Ahh. I only used the save as once, and that was obviously when I was creating the document at the start of it XD.
Other than that, I kept just hitting file > save. Now I know that it does nothing, this is pretty odd.

I’ll keep a look on it, see if I can pinpoint what’s causing it.

thanks for the help.

Are you sure this is not the “zeroed out preferences” bug? The “blank file” is its key symptom. Try going Tools -> Options and clicking the “Defaults” button and then “apply.” If that’s what’s happening your text will magically re-appear. I have a set of saved preferences that I’ve saved using Manage -> Save Preferences just for this bug for when it reappears. And it reappears often.

Hope this helps.

This bug bites enough people, I wonder if it might be worth putting up in an announcement so more people will see it? At least until it gets stamped out for good. Just my .0005 cents worth…