Media Files won't play inside Scrivener

I searched this forum and somebody had already had the same problem but there was no solution was really given. I’m 100% sure it’s not a problem of unsupported formats.

When I try to import any supported media files, whether by dragging or adding through the File > Import > Files, they always show up as a link. I tried with quite a few different files and then I thought that maybe there might be a test media file in the tutorial. There was, the ThisIsBuzzAldrin.wav. So I exported it to my desktop and tried dragging it back into the tutorial (in case there was some settings difference between my projects???), but again it displayed as a link while the one already included plays just fine.

Is this some sort of bug? Also could it have anything to do with VLC player or the file association? I noticed that the imported file icon is the VLC cone, but the default for the included .wav was a video strip. I tried changing the association to something else (Quicktime, Scrivener itself, etc, I don’t have WMP though), but nothing really changes except the icon.

I even tried exporting/importing the project and that didn’t work so it seems like the settings is set in the project files. I poked around the files but found nothing different where the relevant file numbers where mentioned. Is there anyway to force it to play? …or am I missing something really obvious?

Details: 1.8.6 on W7 64bit.

Nothing?

Should I put this in the bugs section or can somebody move it if it is one?

Just to eliminate the obvious - you’re trying to import them into the Research folder, rather than the Draft, correct? The Draft folder is for text only, so media won’t import or play from there.

FWIW I just tested and saw the same results as you - but I’m running WinScriv in a VM on a Mac, and I’ve never installed any media players into Windows there, so hardly the best testing environment. Here the media file (in the research folder) shows up as a link - which when clicked opens in Audacity on the Mac side.

Installing external media players shouldn’t be necessary or affect importing the files or their ability to play in Scrivener. That said, it’s possible there’s some conflict with the codecs in a specific system configuration (I have VLC installed and don’t see this problem, so that alone isn’t causing the issue). In the case of the tutorial project, does the audio file there appear properly and play in the editor, and the problem of it appearing as a link only occurs when the file is imported into the project?

Are the projects saved locally or are they on a network or external drive?

Yes, I’m importing into the research folder.

“In the case of the tutorial project, does the audio file there appear properly and play in the editor, and the problem of it appearing as a link only occurs when the file is imported into the project?”

Yup, plays in the editor, it only happens if I try to import it into any project (including the tutorial itself).

The files on my project are saved “locally” on my google drive folder. They used to be saved just in my documents (though on a second internal HDD since I’m using an SSD for my C drive). I just tested making a project in my C drive just to be sure but same thing happens.

I think it’s a problem with the import feature, like it’s automatically designating it as a file it can’t play. I just wish I knew where in the project files it does this so at least I could manually fix it for the few files I have until a fix is found.

I’m going to try on a computer with a fresh install soon to see if anything changes.

Once the file is imported, are you able to open it in a player via Documents > Open > Open in External Editor or by clicking the link? I’d assumed so but I realise you never specified, and it’s worth checking. You could try also copying the link (right click on it in the editor) and then pasting that in Windows Explorer’s address bar to navigate to the file within the project and make sure the imported file looks correct there–right file type, right size, opens in an external player, etc. Just to make sure that the actual copying of the file worked properly, and the issue is with the project not recognising it.

Since you have another computer to test on, try copying one of these projects with the imported audio files to that other computer and opening it there. Do the files still open as unsupported links, or do they now open correctly? Or if you could create a sample project with one of these problem imports and then zip it up and attach it here (you’ll need to change the extension for uploading it, the forum rejects .zip files I believe) or sending it to windows.support AT literatureandlatte DOT com attn: Jennifer, I’ll take a look at it directly.

Yup, the file plays just fine (in VLC or the corresponding external editor) when I click on the link. And they’re perfect copies in the project folder.

I don’t have another computer to test it on just yet (in a few days I will), but I just remembered I did have a Linux VM. In Ubuntu files import properly, but don’t play (though that’s probably something to do with it being a VM), but what I was curious about is whether like you say they would still display as links.
I opened my tutorial project and yup, the copies still display as links and the original tutorial audio shows up in the editor just fine. So something is definitely telling it to display the files as links as opposed to in-editor.

I’ve attached the tutorial files with just the two audio files in the research part. Hopefully you can figure out what’s going on.

Test.zip (559 KB)

Thanks. I’m not sure what’s affecting the import to misidentify the file this way, but you can fix it after the fact if you’re comfortable opening the .scrivx XML file and editing it. Be sure the project is closed, then open that file in a text editor and search for all instances of

Type="Other"

For each case, check the <FileExtension> line below to ensure that this is a media file type that should be supported (wav, mp3, wmv)–you can check the <Title> line as well, to identify the imported file by name–then for appropriate items you can replace the text above with

Type="Media"

Save the .scrivx file after the alterations and when you next open the project in Scrivener, the media files should display correctly.

I’d suggest using File > Back Up > Back Up To...from within Scrivener before doing this, just to be safe, or if the project is already closed, right-clicking the project’s .scriv folder and choosing “Send to \ Compressed (zipped) folder” to make a backup.

This will only help with files already imported; it won’t fix the fact that they are importing incorrectly. I’ve made up a bug report for the issue and included your sample project, so hopefully we’ll be able to sort out what’s going wrong.

Thanks. They now work in the editor. There are some problems with the playback (audio, no video sometimes) you might want to look into as well, but for the moment I’m content with the work around since I’m mostly interested in the audio.

Hi, I am having the same problems outlined above. As suggested I can manually change the file type from ‘other’ to ‘media’ by opening the .scriv file in notepad++ but was wondering if anyone ever found out what caused this error? It’s a bit of a hassle to go through this manual editing process when you are adding audio often.

Thanks for any suggestions!

Thanks for these suggestions, and apologies if this has been answered elsewhere.

I am having similar problems with audio files. I’ve loaded WMA files from an Olympus recorder into Scrivener for several years now without problems, but now (after the 2.7 update) the files no longer play. I tried to use the workaround suggested above but it’s not making the files functional for me.

When looking at the text file, I noticed that most of my media files had already been imported as such, (ie, they are marked as Type=“Media”) but they still don’t play. I often use Scrivener for transcription, so I would love to find an answer to this problem.

(PS: Here is what two of my audio files look like as opened in a text editor. Is there any reason why this wouldn’t play?)

Type=“Media” Created=“2011-10-19 05:36:16 -0500” Modified=“2011-10-19 05:43:50 -0500”>
ActualBhojpuri

Yes
wma
0,0
Yes


0.0



AudioLabWorkers-BhojpuriLanguage

Yes
wma
0,0
Yes


0.0


<BinderItem ID=“22” UUID=“6851FFF3-1A64-4CB2-AFB3-C11DB1B9627F”

Hi there, still have the issues mentioned above, anyone found a solution to this problem?