Merging for export to Word, then splitting

I’ve just started using Scrivener. Each of my chapters/sections is currently a separate file. Ideally I’d like to periodically consolidate them for export as a Word document. However, I still want to keep them as separate files in Scrivener-yet when I try the “merge” feature, a warning pops up that this won’t be able to be undone. Is there a way to combine the files, then split them again without losing anything?
Thanks!

Psst, given that you are describing the entire point of Scrivener, you may wish to take a peek at the tutorial, or refer to the Help file. :slight_smile: (The feature you are looking for is called File > Compile Draft, and it really is the whole point of Scrivener.)

All the best,
Keith

Okay call me a pedant and I know it’s just a typo but I’ve seen this one twice on the forum in the last few days and I just can’t restrain myself:

…the word, in this context, is “peek” not “peak.”

cheers
william

Thanks, Keith! I’ll check it out. I went through the tutorial once already, but suffered a bit of information overload…

Ach, edited, because I can’t stand these things. You would not believe how many words get messed up in my brain when I’m typing at 80wpm after 10 hours of coding. (“Beach” becomes “beech”, “one” becomes “on”, and lots worse besides.)

I do know the difference between “peek” and “peak” (given that I spend plenty of time playing peek-a-boo with my daughter and have not once lost her up a mountain), and it drives me nuts when people write “then” for “than”, so I hate making these sorts of typos.

On with the hair-shirt it is…

Ok, so I’ve figured out the “compile draft” issue and in the course of doing so encountered a new problem. I went through the tutorial, but couldn’t find it addressed there.
In my Scrivener draft folder, all the files show up with the proper indentation and spacing. During “compile draft,” I checked the boxes for Courier 12, double-space, and keep formatting. Yet the word document comes out single-spaced with absolutely no paragraph indentations.
Is there an easy fix for that?

It sounds like you might have some conflicting settings, though nothing too egregious. For instance, if you are not using the compiler’s override formatting system, then there is no need to select a font and spacing. Those tool for are people who are writing their draft one way, and need to publish it another way. To be clear, this isn’t hurting anything. You just aren’t accomplishing anything by changing the text and formatting settings unless you use that top checkbox—so might as well save yourself some time and complexity and just ignore it. :slight_smile:

The second thing (which is probably more likely here given that you have set it up to use your original formatting, and as you say your original formatting is already good) is that you might be using the .doc or .odf exporter instead of the RTF exporter? A loss of line-spacing and indentation is a known bug with the two specialised word processor exporters. RTF will in most cases be the better option. The main exception is when working with a piece of software that doesn’t understand RTF, like some mobile office apps.

Use RTF format instead (which all versions of Word read). Unfortunately we rely on the default OS X .doc and .doc exporters and they have a bug whereby indentations and line spacing get lost (try saving as .doc or .docx from TextEdit and you’ll see the same thing).
Hope that helps.

All the best,
Keith

I knew you knew of course. I have exactly the same problem. The worst one is that if typing at speed I frequently put “it’s” when it should be “its” or simply throw in random apostrophes before a final “s.” Given that this is a pet hate of mine it’s very galling.
w

I have the same problem - the grocer’s apostrophe appearing in my own posts! I remember at school, when I was eight or nine, being lectured in an assembly about the difference between “there”, “their” and “they’re”, and thinking how retarded the other kids must be not to know the difference. And then, only after this assembly, did I ever find myself lapsing when writing quickly - damn centipede thinking about all those legs!

Sorry to keep beating this particular dead horse, but I’m clearly drowning in my Luddite-ism…
I saved the manuscript as an RTF file, which worked like a charm. However, it needs to be a word file to send to my editor, and trying to convert it from RTF to Word produces the same end result (no formatting). So is there a next step?
Thanks to all of you for your patience and help-
Michelle

When you’ve opened it in Word, just use Save As in Word to save it as a .doc or .docx file if necessary (saving to these formats from Word won’t cause any problems). Your editor would be able to open the RTF file in Word, by the way, but I do understand that depending on your relationship with your editor, it might not be an option to explain to him or her that the RTF format is something Word can open…
All the best,
Keith

Worked perfectly, Keith, thanks.