Meta Data fields not editable in Compile - project shared?

In Finder, I have a Scrivener project that has a folder icon with “two figures” on it rather than the standard Scrivener project icon. Apparently it is indicating that this folder still has some sharing characteristics left over when it was in Dropbox and was being edited by someone else. She completed editing and I copied the folder from Dropbox into a folder on my hard drive. Now, when I try to edit the Meta Data in Compile, the fields are greyed out and cannot be edited. I’ve tried every way I can think of to get it out of this state. Any ideas on how to fix this? Thank you

Hi,

I’m not quite sure what you mean. What do you mean by “two figures”? And what do you mean by the meta-data fields being greyed out in Compile? Could you please post a screenshot?

Thanks and all the best,
Keith

Sure, I have attached three .png format screenshots.

  1. The Dark Horse folder showing that the Scrivener project is contained within a folder with 3 stick figures, (not two), indicating it’s some kind of a shared folder. see attachment 1…png

(2) Note that in my Finder, the Scrivener project icon appears in the column to the right of this folder – indicating that the project is inside the folder. (The problem could be that the project is inside the folder rather than just standing alone as is the following project–DOTEOT. Interestingly, I can open the project either by clicking on the folder, or the project icon.

  1. A comparison .scriv project icon from DOTEOT, another Scrivener project. This is what I’m used to, a “normal” project that hasn’t given me any trouble. Here we see the Scrivener project icon standing alone, not inside the type of folder that contains the Dark Horse project. see attachment 3…png

  2. The Meta-Data tab from the Compile of Dark Horse showing the greyed-out fields. I can move the cursor from one field to another, but I can’t edit the text within the fields. see attachment 4…png

Hope that helps. Thank you, Keith.
Glenn



Hi Glenn,

I’m not sure why the icon is different in the Finder, but those fields are not edited out and are exactly as they should appear. The grey text is “placeholder” text, the same as you see in search fields. It shows you what will be used by default, if you don’t enter something manually. So just click into those text fields and type what you want Scrivener to use instead.

Hope that helps.

All the best,
Keith

I am able to click into the greyed out fields, the cursor positions itself in the far left of the field and blinks. However, I cannot move it within any of these fields or edit the text that is there. Somehow, it appears that these particular fields have become disabled for adding or editing text. The other fields: I am able to position the cursor within each field and add and edit text as normal.

As I said in my reply, these are placeholder fields. You are not supposed to be able to edit the text in them. If you are currently using Safari, look at the top right of the toolbar and you will see a search field with “Google” written in it in grey. That’s placeholder text, too - click into the field and you can’t edit “Google”. These fields are the same, and they are behaving exactly as they are supposed to - they show you what will be used by default, if you don’t enter something different. So, just click into them and type. Don’t try to edit the text in there. Placeholder text in text fields is quite common on OS X.

I am really struggling to understand what’s going on. On other Scrivener projects that I have published, those fields are editable. I attached here an example of one project’s Meta Data that shows the author’s name in a ‘bubble’, the date field and the title field that I entered also. All these fields are editable.

When you say, “It shows you what will be used by default, if you don’t enter something manually. So just click into those text fields and type what you want Scrivener to use instead.”

I can click into the fields. When I do, the cursor automatically lands at the far left of the field and starts blinking and the field acquires the blue border around it. But I am not able to type new text into the field (that is what I mean by “edit”, not edit the placeholder text itself).

I’m struggling to understand the confusion. :slight_smile: Try clicking into the Google search field in the right of the toolbar in Safari. It says “Google” as placeholder text. When you click into it, the cursor is to the left and you cannot edit the word “Google” - because that is just placeholder text. Same thing here. You have manually entered a title into those other projects and so you can click into them and edit them. In the project where the text is grey, you haven’t entered anything, so Scrivener is showing you what it will use if you don’t enter anything yourself. “Here,” it is saying, “is what I will use in your Compile settings if you don’t enter anything into this field yourself.” Click into the field and that will disappear and you can type whatever you want. Clear the field and the placeholder text will appear, meaning, “If you leave this field empty, this is what will be used.” As I say, this is a fairly standard OS X convention. That text field is empty; the grey text - placeholder text - shows what will be used because it is empty. It is not real text, but more of a ghost…

:smiley: Ok, duh, now I see that all I have to do is click in the field and start typing. I think I was hung up on having to delete the placeholder text first and of course it wouldn’t allow me to do that. Thanks for being so patient and seeing me through this.

No problem, glad it helped. I’m used to placeholder text in search fields and Apple use them a lot in some of their pro development tools, so I was bit blind to how they might not be so common elsewhere; sorry it took me a while to understand and explain it properly!
Happy New Year!
All the best,
Keith