Meta-Data placeholder won't expand when compiling for mm

Hi all,

I am trying to get the following metadata header when I compile my document:

---
title: document title 
categories: category1, category2
tags: tag1, tag2
status: publish (or draft)
---

To accomplish this I have attempted to create some new Meta-data entries when I use the compile for multimarkdown option.

I have created a Key called “title” and attempted to use <$title> with no luck. The place holder never expands to the document title during compile.

I have attempted to expand the custom category meta-data by using something along the lines of <$custom:categories> with no luck at all either. Can anyone let me know what I’m doing wrong? Does this require editing of the XSLT files?

Thanks

They token you are looking for is <$projecttitle>. <$title> is a document level token, printing the title of the current piece of the draft the compiler is processing, and is meaningless in the context of the meta-data pane.

Likewise, custom meta-data keys are all document based, not draft or project values. Each individual document in the draft could have their own meta-data values, so there wouldn’t be anything to print at the very top of the output.

Why not just type the values directly into the meta-data compile option pane? They only get used once.

Hi, so to step back, I am using scrivener to create individual blog posts nested within each project.

So I have something like:

2012

  • blog post1
  • blog post2

When I compile, I want to compile just the markdown output for blog post1 hence why I need the $title since each blog post is named after the document title. I don’t think it would be efficient for me to reference $projecttitle since I would have tons of projects just for a very short post. I don’t want to manually type each title in since that would be very inefficient in my eyes and could cause discrepancies if I needed to repost hence why I want to pull the $title from document + the keys from my custom meta data values.

Okay, I see what you’re driving it; I thought this was for just one document in the project. Honestly I think using the binder based meta-data system is better for multi-product projects like this. If you haven’t done that before, you just type the meta-data into a binder document and call it “Meta-Data”. You want to make sure that is the first item in the Contents compile option pane so that it doesn’t get treated like a regular section of the draft. Here is an example:

2012
	 blog post 1
		 Meta	Data
		 Section one
		 Section two
	 blog post 2
		 Meta	Data
		 ...

But if you wanted to stick with the compile meta-data pane, you could use the <$compilegroup> token. That will print the name of the container you select to compile. So if you choose “Blog post 1”, that is what would be printed.

That still won’t address accessing item level meta-data values from the compiler though. There’s just no way to do that. But then that’s not a problem if you use a Meta-Data document for each article. Then you can probably dispense with the custom meta-data altogether if that is all you are using it for.

AmberV,

I think I was over thinking the issue. I just embedded the header into the document itself and it compiled with no issue. Thanks for filling me in on the placeholders not working at the document level on compile, very helpful. I think I’ll be leveraging a template to create default documents with this header.