Minor but reproducible bug: help menu / tutorial

Hi,
I doubt this bug is a show-stopper for anyone but it’s worth checking. I ran into it as a new user trying to learn more about the software.

Steps to reproduce:

  1. Close all Scrivener projects.
  2. From Help Menu, choose Tutorial.
  3. Got to Help Menu, choose Tutorial again. (Yes, a second time, even though it is already open.)
  4. Close the Tutorial.
  5. Try to open the Help Menu again —> Scrivener crashes!

That’s it. I’ve tried to boil it down the the simplest number of steps. Let me know if anyone can reproduce it.
My Setup is:
MAC OS: 10.5.2
Scrivener: 1.11

Love Scrivener so far!!
Cheers,
Ryan

Hi,

Thanks for the bug report. I can’t reproduce it so far, but there is another crashing bug associated with the Help menu (typing “Typewriter” into the Help search bubble and selecting items in the menu that comes up with the Typewriter Mode option in it), so it may be related. I am looking into that bug shortly anyway, so I will try to reproduce this bug again then.

In the meantime, if you could post the crash report, that would be really helpful.

Thanks again and all the best,
Keith

Should I post the crash report here or email you directly? (The real question: Are there any security issues with putting crash records on public forums?)
~R

Small update:
I reinstalled Scrivener on my Macbook Pro, restarted the machine, and the crash is still produced in the same way with the same steps.
I then did a fresh install on an iMac and tried it and also got the same crash there as well.
Both are system 10.5.2

~Ryan

You can post it here or e-mail me at support AT literatureandlatte DOT com. (There aren’t any security issues that I know of with posting crash reports on a forum.)

As I say, I can’t reproduce it on my MBPro running 10.5.2.

Best,
Keith

Crashlog sent :slight_smile: