Minor discrepancies in tutorial.

I have just downloaded Scrivener and I am going through the tutorial and thought I would post about some discrepancies that I have come across. I had not changed any of the settings prior to starting the tutorial so all the settings should be the default settings.

Part 1 Basics: Step 2 Header View: The header view was not showing by default. I was able to fix this and follow along with the tutorial by going to view > layout > show header view and it did take a few minutes to find where it was located for me to change it. Nothing major just may be confusing for some.

Part 1 Basics: Step 3 Footer View: Same thing as with the header view it was not showing by default and I was able to turn it on without problem going to view > layout > show footer view. Again nothing major just something that may be confusing for some.

Part 1 Basics: Step 3 Footer View: In following the tutorial it asked me to click on spacewalk_info in the research folder. I did so but it was just a blank page(not sure if intentional or not) The only thing that was actually functioning under research for me was the Alhambra picture.

Part 1 Basics: Step 5d references: When going to the Inspector under the references tab it says to click the + to add references but there is no + in the references pane there is a very tiny down arrow. Again nothing major just pointing it out to try and make this program as great as possible.

Part 1 Basic: Step 5f snapshots: It says in this section that you can take a snapshot by hitting ctrl+D however when going to the Documents > Snapshots menu it shows ctrl+5 as the shortcut and hitting ctrl+D duplicates the current document(which it also shows in the menu)

Part 1 Basic: Step 6 End of part one: When it tells you to take a look at the group mode segmented control bar it says it should like this but there is no picture of what it should look like.

Part 2 Organization: Step 8 Splits: When splitting the document either vertically or horizontally the second pane does not have the header or footer on by default though the tutorial leads you to believe that it should be. Fixing it was no problem going through the menu.

Thanks for collecting these notes! The tutorial (and user manual) will be completely revamped and up to date for final release. We’ll make sure to take these into account.

I’m using 029. Observations on the tutorial :slight_smile:

A. When I first create the new project, the tutorial starts on Page 18 out of 19 Pages. (It does say “So, without further ado, click on “Step 1: Beginnings” in the list on the left to begin.” but it’s kind of odd when it automatically starts on the second to last page.)

B. About that “click on “Step 1: Beginnings”” – It’s not immediately visible. You need to go digging for it.

C. Having found “Step 1: Beginnings”, the very first line is “Let’s take a closer look at “Scrivenings” mode.”. Closer than what? I thought the tutorial just started. Did I miss something?

D. Still near the top of “Step 1: Beginnings” it says (near the top of the page) "We already did (1) in Step 7, so let’s try viewing arbitrary documents this time. " strongly implying that one is meant to do Step 7 of the tutorial BEFORE Step 1. Bwuh?

E. Immediately after the implication that we’ve already done “Step 7”, the “Step 1: Beginnings” tells you to go to “Start Here”. How many beginnings ARE there to this tutorial? First page 18, then page 1, then page “start here”. It’s rather disorienting to have so many beginnings.

F. Finally arriving at “start here”, I get a weird sense of deja vu. It’s kinda-sorta like the “Page 18” that I started on, but not exactly. It does have the same “So, without further ado, click on “Step 1: Beginnings” in the list on the left to begin.” as the initial Page 18 though, sending be back to Step1. (remember “You are in a maze of twisty little passages, all alike”?)

G: Now the “Step 1:” is saying to ‘ensure that the stack of papers is selected in the “Group Mode” control in the toolbar’ OK, it’s not rocket science and I can figure this out, but it’s kind of weird being asked to “ensure” something about a setting that hasn’t been introduced yet. While I’m still trying to figure out where the tutorial starts.

H: Also, having the tutorial begin with instructing you to take a sequence of steps that take you away from the page displaying the sequence of steps – thus forcing you to (attempt to) memorize the steps while the program is still brand new (and possibly not entirely succeeding) – adds to the “wandering around in a maze” feeling.

I: Now “Step 1” telling me what “The Inspector” displays, without telling me what “The Inspector” is, or where it can be found on the screen. Again, I can figure it out – but I’m starting to worry that if my lantern goes out, I’ll be eaten by a grue.

Maybe it’s just too late at night for me to be working on this, but I’m finding the tutorial incredibly confusing despite having been happily using Scrivener for the past month. And I’m still on the first step. (At least I think I am. With all the different beginnings, it’s hard to tell.)

Loving the program, though, despite my (possibly sleepiness induced) befuddlement with the tutorial.

OK, poked around some more. Since “Step 1:” seemed so badly out of place, I decided to see if it had been accidently swapped with, say, “Step 11”, which is called “Scrivenings” (which “Step 1” wanted to take a “closer” look at.)

“Step 11: Scrivnings” says “This brings us to the end of part 1 of the tutorial”, despite the fact that it’s the 5th out of six steps in Part 2.

This makes me curious what “Step 6: End of Part one” says. Turns out it tells one to go to “Step 16”.

So, I started clicking on all of the items, looking for something that looked like it was the REAL “Step 1”.

I discovered that “Step 4: Full Screen” (the fourth of six steps in Part 1) begins by saying "Welcome to Part 2 of the tutorial.

“Step 5: The Inspector” just talks about importing files from other programs. That doesn’t seem right…

“Step 7: Changing Editor Views” (the first step in Part 2) is the most beginning-friendly place I’ve found yet, starting by saying that “Scrivener’s editor has four modes - four different ways of viewing your work - and learning how and when to switch between them will make your Scrivener experience much more comfortable. The four modes are as follows:”. This page I can read as a beginner without feeling lost – unlike any of the pages in Part 1.

“Step 8: Splits” Talks about Saving, Layout, and Scratchpad. What’s a split, and what does it have to do with these this?

I’m not sure what “Step 10: Outliner” is about, but it doesn’t seem to mention the outliner at all.

“Step 13: Importing” is completely blank. I guess because importing was already covered in “Step 5: The inspector”.

“Step 14: Exporting” doesn’t mention exporting files. Just splitting them.

“Step 15: Compling the draft” seems to be giving basic information about the interface – explaining “The format bar”, “the format menu”, etc.

“Step 17: Text editing” seems to have exactly the same content as “Step 15: Compling the draft”, but it’s formatted slightly differently.

Edited again to add again:
Now I looked at the sub-files to “Step 5: The inspector”

5c Notes: Is talking about the outliner, compiling, and organization. Doesn’t seem to mention notes.

5e Keywords: Is talking about compiling PDFs.

Thanks, LindaJeanne.


You might want to try deleting your current tutorial project and creating a new one. It sounds like your project’s gotten really out of whack–there are certainly some discrepancies still in the tutorial, but nothing like the mismatched documents you’re seeing all over the place. With the project closed, navigate to its .scriv folder in Windows Explorer and just delete the whole thing, then in Scrivener select “Interactive Tutorial” again to make a new copy. There is a weird bug where you might get the interface here looking like how you left it in the last project (e.g. a fresh 029 tutorial project should start you out at “Start Here”, but when you create a new project it will open on whichever document you were last viewing), but it should recreate the project fresh otherwise, hopefully with all the documents in the proper places and associated with the proper titles. If the steps aren’t expanded in the binder, click somewhere in the binder and then choose View>Outline>Expand All to reveal all the subdocuments. (That should be done by default but I know currently it’s one of the things that needs to be fixed.)

You may’ve already gone through the tutorial, as much as possible with all the oddities you were seeing, and so not really need this, but it definitely sounds like your project was particularly messed up, so I’d be curious, if you have a moment, to know if trashing it and creating a fresh one helped at all.

I’m having the same exact problem as LindaJeanne. I deleted the tutorial 3 times and started over and it still occurred without fail.

Additional item in the Tutorial:
Currently Step 1 (Beginnings) introduces Scrivener mode. The instructions to arbitrarily choose items to combine is not correct. It currently says to use “shift + click” when it should say to use “ctrl + click.”

Shift-click should work, as does Ctrl-click. These both work the same way as in most other programs, including Windows Explorer. Shift will extend the range of the selection between the current spot and wherever you click, so you can easily select a dozen items at once. Ctrl-click does spot selection in a toggle fashion. So by example, if you click on ‘a’ and then shift-click on ‘e’, the selection will be a+b+c+d+e. If you then ctrl-click on ‘c’ and then ‘f’, the selection will be a+b+d+e+f.

I’m having the same problem, too. The entire tutorial seems to be scrambled to the extent that it’s impossible to use. I was already pretty confused after Step 1: Beginnings, which deals entirely with the Scrivenings mode and tells me I’ve already tried this mode in Step 7 (hmm?). Step 2: Header View seems just fine to me, but Step 3: Footer View is completely blank. Step 4: Full Screen has no information on the full screen feature; it talks about organising your text documents and folders, and ends with “Okay, move on to Step 7 when you’re ready”. (What about Steps 5 and 6, then?) And so on and so forth… I didn’t go through every item in LindaJeanne’s list, but it seems to me that we’re having exactly the same problems.

I also tried deleting the project and starting a new one, but unfortunately that didn’t help, it’s just as messed up as before.

(As for the Shift + click vs. Ctrl + click thing, the tutorial explicitly tells you to only select Start Here, Step 7, and Step 11, but instructs you to do this by holding down the Shift key and clicking on the documents you want to select - which of course will select the entire range from Start Here to Step 11, but that’s not what you’re supposed to do.)

Yup, still scrambled the same way. (Except that it started me on Page 2 “Switching headers”, instead of Page 18 like it did the first time I created the project.)

Wonder why it’s happening for Lisko, KarenWalters, and myself, but not for you?

Lets see, factors…

  • I’m on Windows 7.
  • Since there doesn’t seem to be a way to close a project without closing the Scrivener, I couldn’t try creating the tutorial without having an existing project already open. Don’t know why this should affect it; but it was a reflexive thing to try.
  • I have customized my labels and statuses pretty thoroughly. Don’t know if this would have an effect.

Are there any other settings which the tutorial might be relying on, which are changed globally when a user changes them?

Still no idea what’s causing this, but you’ll be happy (?) to know that I have accidentally replicated it. In some mystical way that I have yet to figure out, I created a new tutorial from the New Project window and it experienced something similar to yours, with pages all out of order and some of them missing text completely. And as far as I can tell, it magically corrupted the original Tutorial project within the installed Scrivener directory, thus simply deleting the project and creating a new one provided no fix, as you discovered.

How that happened I don’t know. On the upside, though, deleting that tutorial project I’d created, reinstalling the beta over the existing one, and creating a new tutorial got it all back on track, so if you’re desperately curious for how it ought to be, you can give that a try; doesn’t take very long. Still some discrepancies, of course, but at least the documents are in order!

I hate to say this, but now, after deleting the tutorial and re-installing the beta, I have another problem. The entire Tutorial is blank.

I’ve attached a screen shot with two images. In addition to no text, it still tries to open Step 18 - Creating a New Project - as the first step.

On another note, after I re-installed the beta, Scrivener did not automatically start even though that box was checked.

I’m using OS Windows 7, Home Premium Edition and Mozilla Firefox browser, version 3.6.22.
Tutorial.2011-09-10.pdf (731 KB)

I deleted the tutorial and re-installed the beta again, hoping the problem with the blank tutorial was a user issue. I’m not sure if it was or not but regardless, I don’t think that should have happened at all.

Anyway, I am back to the original problem. It opens at Step 18 - Creating a New Project - with what appears to be the real first page of the tutorial but it takes me directly to the bottom of the page. When I click on Step 1 - Beginnings, it also opens at the bottom of the page. Now when I click back on Step 18, it takes me to the top of the page. I have not clicked anywhere inside the text.

Like others who posted here, I have found the tutorial to be completely scrambled. I thought I was going crazy – trying to follow along when nothing made sense and it all seemed out of order. I deleted it, reinstalled it, etc, and it still does not work. I have not done anything else in the program yet.

Major disappointment.

This is driving me batty trying to figure out why the tutorial is sometimes getting scrambled. I’m so sorry that it’s all some of you are seeing!

I’ve attached a tutorial project that should be correct–at least, it looks fine for me. :neutral_face: Try downloading the zip file, extracting the project, and just opening it as a regular project (double-click the project.scrivx file inside the tutorial.scriv folder) to see if it give you a normal tutorial.
tutorial.scriv.zip (1.89 MB)

Thanks for the fast reply. And on a Friday night!

That tutorial does seem to work correctly – once I figured out which file to click on to launch it – not having used scrivener before it was not obvious to me.

I hope my scrivener adventure goes better from now on. This was a rather frustrating way to get started!

Thank you.

Whoops, sorry, I should’ve given more thorough directions. (Can I chalk that up to Friday night?) Glad you figured it out though and yes, I hope things run more smoothly for you from here! I will warn you that there are still a few bugs that you’ll find when going through the tutorial–for instance, one I can remember is that when you’re in full screen mode, it will tell you to switch documents and then exit. What should happen is when you exit full screen, you’re still in that new document you switched to, but due to the bug you’ll have bumped back to where you were previously. Just switch documents again in the binder (you’ll have learned how by that point) and carry on. There are a few other things you might come across too–shortcuts might’ve been switched again in the program that haven’t been updated yet for the tutorial. So if you see something that doesn’t seem right, check in the menu–the real shortcut will be displayed next to the command, and that’s the one you’ll want. Hopefully most of it will be pretty clear though.

Welcome to Scrivener and the forums, too, by the way!

I’m happy to report that that tutorial worked quite well. I went through most of it today. Thanks again for finding a solution to the scrambled text! And thanks also for even having a tutorial. So many programs today don’t – they expect you to just muddle your way around, or look up stuff in a “knowledge base.” Only you can’t look up what you don’t know you need!

I’m quite impressed with a lot of the features and I’m hoping to start using this on some writing projects very soon.

I, too, am happy to report your zip file worked well but I’m still encountering a few minor bugs. It opens at Step 18 - Text Editing. I went through each step one by one and it all appears to be correct. Yay! Every so often, though, it would open in the middle of the instructions instead of at the top

All in all, it looks like everything is finally on the right track!

That will (hopefully) be fixed in the next version. There is a big checklist of things I have to make sure are back to “default” when closing up the tutorial project. :slight_smile:

There’s also a bug, which will be fixed with the next beta, where your settings from the previous tutorial are remembered when you create a new one, which just confuses things further. So yes, next round should be better. :slight_smile: