Minor interface issue when saving compiled drafts

Hi!
One small thing i’d like to place on the wish-list:
I use Scrivener in conjunction with MultiMarkdown and regulary compile and export drafts to latex. The workflow doing this requires me to switch from keyboard to the mouse and i would love to stay on the keyboard which is much quicker. :slight_smile:
Current process:

  1. ++e for compiling draft
  2. for accepting the compile draft settings and exporting
  3. for accpeting to save the export to untitled.scriv
  4. Take the mouse and confirm that the file is to be replaced.
    This last step requires me to switch to the mouse as i cannot change the button focus in the dialogue via keyboard.
    As i export the drafts quite often this is a bit of a nuisance but i think a simple keyboard support for this dialogue should do the trick. :slight_smile:
    Cheers
    Silvan

Replace step (4) with Tab - Spacebar. :slight_smile: It’s a good trick to know for the Mac in general. Whenever you see that ghosted halo around a button, that means spacebar will activate it. A lot of applications will set up dialogues so that you can press enter for one action and spacebar for an alternate action. This would be a good place for that, in my opinion.

The “file already exists - replace?” panel has nothing to do with me. It is generated by the Open panel itself - that is, it is part of the OS rather than Scrivener - so I have no control over it.
Regards,
Keith

Thanks for the reply but it ain’t that easy. :wink:
I should’ve written:
I tried all shortcuts i could think of, including , +cursorkeys, +cursorkeys, +cursorkeys, +,…
You get the picture… :slight_smile:

Cheers
Silvan

Hmm, i feared so.
Is it just me or can anyone else use or something similar to change focus in that panel?

Cheers
Silvan

Check Keyboard Shortcuts tab in the system Keyboard & Mouse Preference pane. At the bottom is a toggle that lets tab work on all controls instead of just list and text controls. You would think tabbing between buttons would supersede that setting, but it does not.

:smiley: YAY! :smiley:

That’s it, thanks a lot.
Silvan