Missing text after split

Help! I finally finished the novel outline I’ve been working on for months in Scrivener. I went through the tutorial, but old habits die hard, so I was writing in a single document. Once finished, I thought it was the perfect time to split it into scenes and begin using all those cool features, most notably the corkboard, so I could rearrange the scenes and play with the timeline and subplots to see what worked best.

I put the cursor between scene 1 and scene 2, and went into documents, split with selection as title. Scene 1 appeared in the window by itself, and a new, separate file slugged “Untitled-1” appeared below it in the binder… but the new file was completely empty.

Again, old habits die hard, so after internally freaking out for a moment, I did what I always do: I hit CTRL Z to try to undo. When that didn’t work, I closed Scrivener, hoping it hadn’t autosaved and my cherished outline would be there when I reopened it. Of course, it wasn’t, and after searching the forums, it looks like closing Scrivener means I will never be able to recover all those missing scenes. Is this true? How did this happen, and more importantly, how can I prevent it from happening again?

One side note: I do backup to an external hard drive periodically, though it’s been a while.

Hi HammyCat,

I’m so sorry you’ve lost text! I haven’t seen any other reports like this and haven’t been able to reproduce it myself yet, so I’m afraid I can’t tell you what caused it. Did you have the editor locked when you did the split (the header bar would be red rather than blue or gray)? I ask because, since several betas back, splitting a document in an unlocked editor should automatically switch you to being in the newly split off text, not the first part, and as I haven’t been able to reproduce this bug of the text disappearing, I want to make sure I’ve got all the factors included. Additionally, “Split with Selection As Title” ought to title the new document with the text from your selection, although if you had simply placed the cursor in the document without selecting any text then that would explain how you got the name you did, if your original document was just “Untitled”.

If you can think of anything else that you did or that happened when you were working around the time of the split, please let me know. Likewise, if you can reproduce this (in a sample project!), if you can give me the exact steps that would be fantastic. Meanwhile, a few things to try for finding your text:

First, I assume you’ve probably already checked simple things like that the text is mysteriously invisible/colored white. (No idea why it would be, but stranger things have happened.) Also do a search in your project for some words from the missing text and see if anything crops up. Assuming it doesn’t, try also doing a search for some unique words or phrases from the text via Windows search, as it’s conceivable that the text exists as a lost file in the project directory but isn’t appearing in the project itself.

Thanks so much for the suggestions. Although none of them worked, I gave them a try… I would never have even thought about the text changing to white.

Alas, I haven’t been able to re-create the problem, and I’ve been reticent to delete the empty “untitled-1” file for fear it’s there, typed in invisible ink, just waiting for me to say the magic word to restore it. But I’m finally ready to admit defeat and start from scratch. Hopefully the tears on my keyboard won’t short-circuit the computer :smiley:

To prevent future tears (or reduce them anyway), get in the habit of visiting File->Back up Project to… every day that you touch your project. You can even go to Tools->Customize Toolbar to add the Backup icon to your main toolbar (the one with the big icons), so it’s just a single click away.

Thanks! I’ll definitely be doing that! …and now back to re-creating my outline. If it wasn’t good enough to remember, I guess it’s good it’s gone.

So sorry you weren’t able to find the text! I definitely second the backup advice. And if you do get this again, please let me know! I’ll continue trying to reproduce it, but so far no luck.