Missing text when copy and pasting [BUG LOGGED]

When I copied and pasted my rtf document into a file, it seemed to work well. As I divide it into sections I’m encountering an interesting thing. In the screenshot I’ve attached, you’ll notice some large blank areas in the story. Paragraphs are missing from those areas.

Here’s what happens.

  1. Copy and paste story from OpenOffice generated .rtf file to Scivener.
  2. Label it Original for clarity.
  3. Confirm that the entire story is there.
  4. Cut section from the story and paste it into a new document within the draft.
  5. Label it Section 1 for clarity
  6. Go back to Original and scroll through. Some paragraphs are now missing in later sections that I did NOT cut and paste from.

This happens with .rtf and .doc. The file is 34,000 words, just in case it turns out to be a length thing. I am happy to give you the original file for trouble-shooting but would prefer not to upload it here.

This doesn’t have anything to do with your bug, but just wanted to make a quick note that the Split tool is designed for this kind of procedure. Check out Documents/Split/Split at selection. Just place your cursor where the new section starts, split, then find the next section, repeat. A lot easier than making new files and cutting and pasting. Also when you do this, any meta-data you set up will be propagated to the newly split off file.

Thanks! I’ll try the Document/Split option. For some reason I thought that “split” wasn’t fully working in the Windows version yet. But looking at the tutorial I see that it’s the splitting of windows not the splitting of documents that’s still in progress. I’ll give it a try and see if it helps.

Meanwhile, I’ve been playing with it further and thought I’d offer what I’m finding.

I thought that I would try cutting and pasting smaller sections from the original .rtf file to see if it was a length issue. When I paste them into Scrivener, all the text transfers perfectly. BUT when I click on another document within the Scrivener draft and then go back to the bit that I just pasted in, the text is missing again.

  1. Cut text from .rtf story.
  2. Paste into “section 1” in Scrivener
  3. Confirm that text is all there.
  4. Click on “section 2”
  5. Click back on “section 1” and text appears to be missing.

It’s the same chunks of text every time that go missing.

I also tried clearing the formatting in the original .rtf but continue to have the same problem.

Well, this is fascinating. If I put the cursor in front of a section with missing text and “split at the selection” then the missing text reappears in the new selection.

I experience a similar problem, only on a smaller scale.

1.I was copying and pasting from a .docx file into the comic format (347 words total)
2. the last four or so lines didn’t show up.
3. I copied and pasted again, and then went to another window within Scrivener,
4. when i came back the same four lines were gone.
5. so i just copied and pasted again.
6. when i came back again to double check it all three of the copies were there.
7. i’ve been going back ad forth and so far they’ve stayed.

Hi Mary,

Thanks for cross posting to a similar issue. Clearly this is a bug which we’ll hunt down to fix.

Another thing you could try just to get your work into Scrivener is to cut and paste the entire document into Windows Notepad (which will strip all the formatting and rtf tags) and then cut from Notepad into Scrivener. You’ll have to re-apply formatting in Scrivener but you should get your text across no problem.