Missing vcpp runtime folder in Scrivener\resources: v1.2.3

I’m running on Windows XP Pro 2002 SP3 (32-bit), and I got the following error after installing 1.2.3 tonight.

“This application has failed to start because the application
configuration is incorrect. Reinstalling the application may fix this

I installed the Microsoft Redistributable C++ Runtime, but even after uninstalling, rebooting, and installing 1.2.3 again, I got the same message.

After uninstalling and rebooting again, I found the TROUBLESHOOTING message at the bottom of the readme, and tried to find the “vcpp runtime” folder in my Scrivener\resources folder, but it’s not there.

What am I doing wrong?


If Scrivener fails to launch and the following Windows error message
“This application has failed to start because the application
configuration is incorrect. Reinstalling the application may fix this

This is due to the Microsoft Redistributable C++ Runtime not being
installed on your machine. This is easily fixed by opening Windows
Explorer and navigating to the folder where Scrivener was installed.
In the Scrivener folder, you will find a folder called ‘resources’;
in this folder is another called ‘vcpp runtime’. Open the ‘vcpp runtime’
folder, double-click on the ‘vcredist_x86.exe’ file within it and
follow the installer prompts to install the missing Microsoft
Redistributable C++ Runtime files.

If you installed the 2008 C++ library, it should be the same one as was distributed with Scrivener. Did you install the 2008 one? It’s different from the 2006 and 2010, I believe.

Yes, it was the 2008 version. I wonder if it’s some other Windows XP issue.

Thanks for your response!

It might be worth checking that it must specifically be this one.
It should not be confused with the 64bit version also available.
As a number of developers include this for download and installation with there software it is possible to get a corrupted instal. Hence advice elsewhere to uninstal and do a fresh instal in some cases.
If you need to do this seek or google for further advice as it appears after having spent a day seeking my own answer this requires following specific instructions to the letter.
If you already have the 64bit version installed it should not be an issue to instal the (x86) from the link supplied by Eddie Text shown below.

Good Luck :slight_smile:

“Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)” at microsoft.com/en-us/download … px?id=5582.

In addition do you have XP SP 3 installed and fully patched.
Also after installing Microsoft Visual you need to reboot and check for any patches reboot and reinstal Scrivener to be sure.
Sorry I see you have SP3 installed. :confused:

Thanks for the responses! I was able to re-install 1.2.1 on my XP machine, and that’s working. So it’s all good.

I’m staying away from 1.2.3 for now. :slight_smile:

Hate to rain on your parade, but 1.2.3 has some significant bugfixes over 1.2.1…you probably should upgrade.

Well, bug fixes aren’t much help if I can’t launch the app… :slight_smile:

I am having the same problem - cannot open the program after I installed 1.2.3. I looked for vcpp_runtime and vcredist_x86.exe and cannot find either. I do not understand any of the other stuff in this thread because I am not a computer person. I’ve uninstalled, reinstalled, etc, etc and at this point I just want to remove 1.2.3 but I don’t know how.
What do I do? Any help would be much appreciated. I spent a ton of money to put my kid in camp this week so I could write and instead I have spent two mornings now trying to get into the program that has my book!

Have you tried installing Scrivener on a VM with a naked Windows Installation? Using Linux could even be the fastest way, since a clean install of e.g. Linux Mint or Ubuntu is done very easily and fast.

Just an idea to getting up with writing…

If you’re using a 32-bit system: microsoft.com/en-us/download … LSUS007998

If you’re using a 64-bit system: microsoft.com/en-us/download … px?id=2092

If you’re unsure which you need, Right click “my Computer” or “computer.”