Missing Words from document [BUG LOGGED]

I copied and pasted my novel from Word 2010 into a blank Scrivener document. I had some trouble with words disappearing from my document as I tried to split it into chapters. I figured out if I used “select all” from the “Edit” option and then changed the font size, the words came back. So I managed to get everything split.

Now as I go back and look at the chapters, the words are missing again. When I click on “Draft,” all the words show up, but in the individual chapter files, I have missing sections from the chapters. :frowning:

More missing words! I changed the font of my project to Times New Roman and chapters three through ten disappeared! The folders are still there, but the documents are blank.

I had pasted chapter by chapter to try to get rid of the other missing word issue that I had when using the split. Everything looked fine at first, but as I went back into the chapters individually, I noticed missing words again. So, I decided to change the font. I changed it in chapter one with no problems by clicking on the chapter one folder, selecting all, and then changing the font. I repeated the procedure with chapter two, and that’s when chapters three through ten went blank.

I think I’ll go back to trying to import the document and then try the “split at section” to see if the words vanish again. :confused:

Let us know if that works better for you. I’ve seen one other thread were large-scale copy and paste cause things to disappear sporadically. Of course this copy and paste bug needs to get resolved, but hopefully you can get around the current problem with RTF import and split

Nope. Importing didn’t make it better. I just imported my file (saved from Word 2010 into rtf) and I have missing words again even before I did the split this time. I went ahead with the split, but sections of the words are still missing (I’ve only split two chapters so far). I changed the font (to Times New Roman) in the first chapter and the words came back. Then I went to chapter two and changed the font there. Again the words came back. When I went back to chapter one again, the words that had just been there after the font change before were gone again.

I’d be happy to save the file and email it if someone needs to take a look at it (I can also send the rtf file I imported). You can tell where the sections of text are missing because there are large gaps between (and chapter headings are missing). Then you can change the font and see the words come back and then disappear again.

I think I’m going to give up for the night because I’ve done everything I can think of to get the file into Scrivener (other than retyping the whole thing). I’ll try again tomorrow. :slight_smile:

I mentioned having the same trouble in another thread.

As a data point the lines will reappear if I do the following.

  1. Put cursor at the end of the last sentence before the missing text.
  2. Hit delete. The text magically appears.
  3. Repeat until all the text is restored.

HOWEVER when I come back, the same text is missing again.

Please don’t do that. :slight_smile:

Have you tried pasting in fragments… say 5,000 words at a time? I’m not sure how large your manuscript is, maybe that would be ridiculous, but it might help narrow down if this is a scale issue or a content issue.

AmberV, I’ve tried it with 1500 words at a time and still have the same issue.

Hi Joan,

Can you email me the rtf file and I will take a look at this for you. My email is lee AT literatureandlatte DOT com. I’d be interest to not which rtf tags are causing issues.

Another thing you could try just to get your work into Scrivener is to cut and paste the entire document into Windows Notepad (which will strip all the formatting and rtf tags) and then cut from Notepad into Scrivener. You’ll have to re-apply formatting in Scrivener but you should get your text across no problem.

Thanks

I’ve also experienced missing text after using the “Split with Selection as Title” command.

  1. Under XP, using an rtf file created in Word 2007, I copied text from Word 2007 and pasted text into Note Pad.

  2. I then copied and pasted that text from Note Pad to an open Scrivener text file. (All text appears to be present.)

  3. Using “Split with Selection as Title,” the section below the split drops paragraphs.

#

Lee,
Thanks for the developing a PC version of Scrivener! It looks great.
You must be overwhelmed by the response.

Steve

Just adding a little more information: I think the words are “there”, just somehow not in view.

While trying to copy text from an RTF document opened in Word 2007

Reconfirming above experience: I did the repositioning cursor at the end of the line, and pressing delete to “recover” the words, too, although, like the original poster, the words go away again when I reload the document.

However, just for kicks, I highlighted the affected text (some of the text before, after, and including the blank space where the missing words should be), went to notepad, and pasted… and they were all there.

For further kicks, I re-copied the notepad text, went back to to my original place in Scrivener, pasted it back into the same section… only to recover a few lines of the missing words, and lose the rest of the excerpt coming after those few lines.

Then, when I pasted into a new blank section in Scrivener and everything there where it should be.

It really does sound like something we copied from the RTF document in Word screws up something.

As a final experiment, I then opened the RTF document in WordPad. Copied the same text. Pasted into Scrivener…and all the words were there! (Although I can see the formatting in WordPad, upon pasting to Scrivener, all the formatting is gone).

I am having the same problem, some words disappeared when I pasted my document in. I thought maybe it was some mistake on my part, so I tried to retype them where I thought they belonged and they reappeared as soon as I started typing again.

I had this issue as well when I copied text from a webpage into Scrivener. The text that disappeared when I closed the program was initially formatted in Scrivener like a hyperlink (blue underlined text), even though it had not been a link on the webpage and the formatting toolbar indicated that it was neither blue nor underlined.

The text that disappeared (and was initially highlighted) included both full words, sentence and paragraphs, as well as individual letters at the beginning of sentences/paragraphs. I also lost all line breaks upon re-opening the document.

I overcame this issue by going back and pasting the text without formatting (ctrl+alt+v). Luckily I hadn’t gotten very far!

For what it’s worth, the text reappears for me if I go to View -> Show Invisibles. Then when I quit, change documents, or leave that file, the text disappears again.