MMD compile to FODT

Is anyone else getting an error when they compile MMD to FODT? I’m getting a General Input/Output error in LibreOffice 4.0 when I try and open it. I just updated it, and had the same problem in LibreOffice 3.6 the other day. It worked in Scrivener 1.2, so I’m wondering if it’s a bug in 1.5? I don’t have OpenOffice to try it, but since they are just short of the same program (from the same codebase) I would guess I’d get a similar error.

You would need to install a module into OpenOffice to read the .fodt file, and chances are it would be the same thing LibreOffice uses. LibreOffice is basically just a tuned version of OpenOffice with some stuff built-in that is otherwise difficult to add yourself; it’s a bit like a packaged version of Firefox that is distributed for web developers with a bunch of useful extensions and modifications made to it.

As to the error, contact MultiMarkdown support and send a sample .fodt file that doesn’t open. I have seen this happen a few times myself, and I think that perhaps there are some formatting errors in the output. There is another program on the Mac that can read .fodt, and it always bails out on the same files that LibreOffice refuses to open, which leads me to believe there is a syntax error in the file.

Strange, I actually had no problems with it on 1.2 versions of Scrivener. I didn’t think Libre/Open Office needed a separate module to read those. I’ll check that first.

Version 1.2 only had ODT output, not MMD->FODT. The former definitely would have loaded in OpenOffice just fine, but that route has very little to do with MMD->FODT. These are two different file formats (though based upon the same overall schema).

Ah, you’re right. I forgot that I didn’t worry about MMD conversion to ODF. I’d usually to MMD -> HTML

I tried MMD 3.7 and that still didn’t work. I’ll get in touch with them to see what can be done.

My experience regarding the MMD-FODT export is that you have to set the encoding for the plain text to “UTF-8” (menu Tools->Options->Import/Export). Otherwise LibreOffice cannot open the .fodt file.

That’s a good idea to enable in general, if you’re working with MMD, as that is the encoding it works naturally in, and probably even assumes it.

Unfortunately, not always. I have to use “ISO-8859-15” for the MMD-LaTeX export otherwise I get compilation problems like: “Package inputenc Error: Keyboard character used is undefined (inputenc) in inputencoding `latin1’.”

Well, that worked. Should there be a note in the tutorial about that, maybe? UTF-8 should be used instead of System Encoding?

Thanks szegan!

The tutorial doesn’t really touch on MMD, but I have added this information to the chapter in the user manual under the Flat ODT section.