MMD -> fotd: Page Breaks & Footnotes

I am writing my document with MultiMarkDown (MMD) and sending the output to Flat XML (fodt) for review with LibreOffice.

My question is;
How can I get consistent page breaks between pages?

The page breaks do not appear to behave as I expected. Most of my
project is made up of individual, level 2 pages of reference text, with footnotes.
The page of text starts with a MMD level 2 heading: “## heading ##”
The footnotes are how I am checking for the page break.

My current settings are

  • All four “separators” in the compile options are set to “Section Break”
  • The compile contents page “pg break before” check box has not seem to have any effect
    ** Level one folders do not trigger a page break “before”, with or without the check mark on the compile contents page
    ** Level two documents sometimes trigger a page break “before”, with or without the check mark.

For about half of the items, things work the way I expected;

  • the heading is printed just below the top of a new page
  • the text is followed by a large white space
  • the footnotes follow the white space

Unfortunately, for the other half, the page break seems to disappear.

  • there is no white space following the section’s text

  • the end of a section of text does not trigger a page break

  • there is a line between the sections of text implying a page break

  • the new section’s heading printed just below that line

  • again, there is no white space following the text.
    it is followed by a line and the heading of the next section

  • the footnotes are still printed at the bottom of the physical page,
    ** they may contain notes from multiple text sections.
    ** they can appear in the middle of a paragraph,
    it is all based on the physical location on the page

It is simply that the new sections are not starting at the beginning of a page on a consistent basis.

The reason we call it a section in most of the MMD outputs is that there is no such thing as a page break in the syntax. The separators option inserts four dashes which get turned into a horizontal rule in most cases (the line you are seeing). The only exception is LaTeX, which does indeed have a page break we can insert as raw code using the HTML comment method. When you have LaTeX set as your output file type then you’ll note the Separators pane displays “page break”.

I would imagine the best way to do this would be to modify the Heading 1 style in LibreOffice to insert a page break before the styled text.