.mobi file not found

I am loving Scrivener and was also loving the compile feature for kindle. It was working great! I compiled my project at least 10 times (deleting them each time, so that I could go back into the binder and tweak things, then compiling it again). Worked PERFECT.

But then, about half an hour ago, it stopped working. I would click “compile” and get the error message “The file “filename.mobi” doesn’t exist.”

I saw, somewhere in the forums, where someone else was getting that same message and was told it was because there was no title entered in the meta data. But there is a title entered in my meta data.

I deleted the kindlegen files, then re-downloaded them from Amazon and reinstalled. Still won’t work.

Thanks in advance for any help!

Yvonne
(I’m using Scrivener for Mac)

If it’s not too large, could you please zip up your project and send it to kb-tech-support@literatureandlatte? I’ll take a look.
Thanks,
Keith

Thanks so much for looking into it, Keith! I’ll send it to you soon.

Yvonne

When you get this error, you can often get a little more feedback by turning on the KindleGen logger. This is in the E-Book Options compile pane, last option available, “Save the KindleGen log file with the Kindle file”. With that turned on, compile again, dismiss the error, and then check the save directory for the existence of a *.log file. You can open that in Console or TextEdit to see more clues on what is causing KindleGen to fail.

All,

Yep, same problem. Log is :


  • Amazon.com kindlegen(MAC OSX) V1.2 build 33307 *
  • A command line e-book compiler *
  • Copyright Amazon.com 2011 *

Error(kindlegen): Unsupported argument -nocopypaste

Totally mysterious.

Any help appreciated.

Cheers,

John

I would like to add - Scrivener is an excellent product! I have just completed a 90,000 word science fiction novel - two edits and now in final, ready to add cover and publish on Amazon. Yeehaa!!

OK, steady on.

Look for - Broken Glass, Book One in the Glass Complex series.
By John Hindmarsh

Cheers,

John

Congratulations on your book!

Using the pasted info above and my own testing, it looks like the new version of KindleGen does not support the -nocopypaste flag, which is controlled by the “Do not allow readers to copy and paste the text” option, right above the KindleGen log option. If you turn that off, you should be able to compile.

I’ve investigated this, and it appears Amazon has not provided an alternative method for doing this. Perhaps they are planning on revoking that restriction? Whatever the case, stay away from it for now, or find an older version of KindleGen if you can.

Excellent. I will try to cure this.

Cheers,

John

Well spotted.

It works!

Thanks.

Very much appreciated.

Cheers,

John

Thanks for the information - as Ioa points out, it seems that (for reasons I don’t really understand) Amazon have removed the “no copy/paste” feature from KindleGen 1.2, so turning on this option breaks the export. I have therefore removed the “Do not allow readers to copy and paste the text” option from 2.0.6’s compile options so that this problem doesn’t occur in the future, but until that’s out, just ensuring this option is turned off should fix it.

Thanks again!
All the best,
Keith