Modify script format color from Compile from specific section type

hey thanks for your answer. Basically I want to be able to mark certain scrivenings as “ModifiedSection”, and have those in red — so when I export my collaborators can see which parts were updated.

So obviously I want to modify only the color, not the other script settings-related margins & indents for action, dialogue etc. (which is probably what “override formatting” does, unfortunately)

I did check “override formatting”, here are a few screenshots.
If you see another method to visibly mark some screenplay-formatted sections types as “updated”, I’m very interested!



Well, as for preserving the script formatting, check these :

(This was in my first reply, but I had removed them (those two extra checkboxes) because I thought it was irrelevant in the end.)

And then what I tested, is that I created a section type for “modified text” assigned to a section layout with “Override text and notes formatting” checked (+ the two others under the brush icon) and the text in red. (As in the above screenshot.)

Then what needs to be done is to assign the section type you just created for modified texts to the documents you modified.
That should render those documents in red. (Pick whatever color you want.)

(If your script requires different fonts and/or font sizes, then :frowning: I don’t see how this could be done using a compile format…)
. . . . . . . .
If the idea is not to have complete documents handled like this at once, but rather just bits and parts of documents → (or in the case where you need various fonts and font sizes as mentioned above) ← , use a character attributes style instead.
(That’ll give you a visual feedback in the editor too – letting you know what’s what.)
To do it this way, make a segment of text the color you wish it to be, then create a new style from it.
image
(Uncheck “Include font family” and “Include font size”.)

It has to be a character attribute style and nothing else; the two other options would mess the script formatting.
image

Then apply that style to whichever parts of a document you wish to be marked as “recently modified”.

Hey thanks a lot

but from the start it’s the same problem, visible in my previous screenshots: the screenplay-related styles aren’t modified at all by “override text and notes formatting”. It only makes the “general text”:

Very strange!! (I did additionally your “preserve tabs and indents” checkbox, which was unchecked, but still - screenplay styles simply aren’t affected at all, unless I’m missing another checkbox somewhere?)

Ah!
You are using styles ??
You shouldn’t.

Styles override everything, at compile.

Else, please further define this:

If in fact you meant “script elements” and are not using styles at all, you’ll need someone using a Mac system to further help/investigate. I would have done all I could, being a Windows user.

I’m not using “styles” in compile:

I just use the standard scrivener method to write screenplays: I set this


…, choose “heading” or “dialogue” or “action” and write.

The only non standard thing is that I imported the style from an empty, just-created Final Draft 8 document, to have the same industry standard formatting/page count (and use Courier Final Draft instead of Courier Prime):

Could that be related to those screenwriting “elements” (let’s not call them “styles”) not being touched by “override text and notes formatting” ? Maybe. It might be also related to me being on a mac… :thinking:

to be clear, I’m not using styles in compile, and I am also not using styles in the “styles panel”, I’m not using styles at all, anywhere. only screenwriting “elements” (heading, dialogue etc.)

Please do this:
Click on an element that refuses to adapt to the text color you’ve set, and take a screenshot showing it selected + this :

OK.
You need someone using a Mac to try and reproduce the issue.
I can’t do more.

Meanwhile, you could color red a segment that refuses to adapt, and see if it turns black at compile.
That could give one or two extra hints as to what is going on…


What I get:

Screenshots source

image

image

image

image

COMPILED:
image

(Which, by the way, just made me realize that although there is a way to preserve the script format’s indents and alignments, it messes up the line spacing… – Unless you don’t mind it being the same everywhere; in which case you’d just have to set it right in the compile format.)

To take a guess, I’d say this to be where your issue comes from :
image

It should be gray (or that’s at least how it goes in the Windows version), as in “no selection made yet” so that it uses the editor’s color.
In the Windows version, I can’t seem to find a way to revert it back to this state once a color was selected.
So, perhaps

is what messed it up for you.

– Over and out –

Hey, thanks for your help

I tried creating a brand new blank project, it has the original, default screenwriting elements (courier Prime etc.), and there too all elements are “black” and there is no way to remove that black.

I tried exporting with the same compile, it does exactly the same thing - screenplay elements refuse to be overridden by any Compile settings… :thinking: :cry:

I’ve also tried to add a “*” in the beginning of each line for all documents of a certain section type, but I don’t think the option exists?

Through all of this, did you try, at some point, to create a character attribute style of the desired font color and apply that to your text ?

Thing is, if I do this - mark every updated line by hand - I need to go through all of these after, to set them back to “non-updated style”, which is tremendously time consuming and error-prone…

I’m a Mac user, but have no experience of script writing, but I do have a question: have you explored revision mode?

:slight_smile:

Mark

You could actually update the style (put the font back to black) then delete it. Which would revert everything it was assigned to to “no style”. No risk of errors, and you’d only need to create a new style next time you need to mark stuff.
@Xianemese solution is also likely to work, now that we’re no longer talking about changing the font color in the compile format.

@DavidS, We don’t have to change styles in the Editor to change them in Compile. Just add the style in Compile’s Style panel and change it there.

Although true, this is beside the point in the present case.

Hey, thanks a lot guys
Actually my solution is revision mode. when I do modifications to the screenplay:

  • for small modifications (tweaking dialogue & actions) it’s just writing/deleting in revision mode
  • and for big modifications to the screenplay’s structure (moving a group of scene earlier around etc.) I’d need to select those moved/added scenes and manually “mark as revised”

then I export the PDF, which has the right color (red etc.) for review

and when I’m done with the revision, I can just do “remove all revision” while having the whole script in the editor (i.e. all “included” scrivenings)

great collaboration guys, thanks for all your help!!
D.

1 Like

2 posts were split to a new topic: Advice for managing comments from readers

You said the OP could change the style’s color to black (in the Editor), then delete the style. I think it’s better to change the style’s color in Compile. Two ways to get the same result … but it’s not the same result. Your method loses the style and forgets what text it was assigned to, which may be useful information.

That is/was the whole point, really.
The user wants to be able to reset.
My post was correct.